Skip to content

Commit

Permalink
app-misc/khal: version bump 0.9.8
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/647594
Package-Manager: Portage-2.3.13, Repoman-2.3.3
  • Loading branch information
Amynka committed Feb 15, 2018
1 parent 5cf5671 commit 2224633
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/khal/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST khal-0.9.7.tar.gz 173401 BLAKE2B a0ab87f8ff4546f589b7cc05586c1aa36cf80760234df00241d9eaaced3bcf37bb8b4bb282c39491f69c9ad6fea0f89af3836c29e23294356847bb88fce645b8 SHA512 24fd1ee472971f029f998b061da719a0dfe4ee9584a5ea237b6cf0c886b5c45d7a7ee4bf9c23c41eb0dd0c5eba0bcabed7a5f05ae486a890150429031e215180
DIST khal-0.9.8.tar.gz 173717 BLAKE2B d17a355bd4eddaaf3cf838bac6e66f6a4a72170d6e166aa9fe00d44295031d336651bbb74e2ab73a6ae85275f02f8bf035b6798e280055dd6e38dd139f30c6c8 SHA512 4c47bd18e7458ca7a6adf0684872923b4e49e6bfe481269cf9f77dee29dd47dbacf0d557890080618b4d3f08766fc8fae32de7682167642f0705e5b3b6b5dc01
43 changes: 43 additions & 0 deletions app-misc/khal/khal-0.9.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python3_{4,5,6} )
PYTHON_REQ_USE="sqlite"

inherit distutils-r1

DESCRIPTION="A CalDAV based calendar"
HOMEPAGE="http://lostpackets.de/khal/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="zsh-completion"

RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
>=dev-python/click-log-0.1.3[${PYTHON_USEDEP}]
dev-python/icalendar[${PYTHON_USEDEP}]
dev-python/urwid[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
>=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
>=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
zsh-completion? ( app-shells/zsh )"
DEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
dev-python/freezegun"

DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )

src_install() {
distutils-r1_src_install
if use zsh-completion; then
insinto /usr/share/zsh/site-functions
doins misc/__khal
fi
}

0 comments on commit 2224633

Please sign in to comment.