Skip to content

Commit

Permalink
dev-libs/cppcodec: Version bump to 0.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.47, Repoman-2.3.10
  • Loading branch information
SoapGentoo committed Aug 25, 2018
1 parent 9edabe5 commit 22369d8
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/cppcodec/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cppcodec-0.1.tar.gz 26932 BLAKE2B abfe4aa3126d5900f806682c6ecb60d3cab5eb41e21d68c3f0c55d011c528304be9d286e48c6dac7bd3edea9e519609091053b6aeb2ab85818837b10499b24ae SHA512 8b406755b3d9457e4e265f76abcb7a18daa4566ec9b56ac3a01b44fd62062eef8d91806e0009ce26ade92a35c5c0488eeaf7db695479a2013f8549ac5fa8626f
DIST cppcodec-0.2.tar.gz 33984 BLAKE2B 248487326d3fafb104d469d16cddab86fe63dec6eecb74af6211c262a42ff8806ee97619459f9dca648107748e30268206e84d64efba47a9ea1c398eb4c06919 SHA512 50c9c81cdb12560c87e513e1fd22c1ad24ea37b7d20a0e3044d43fb887f4c6494c69468e4d0811cd2fc1ae8fdb01b01cfb9f3cfdd8611d4bb0221cbd38cbead3
39 changes: 39 additions & 0 deletions dev-libs/cppcodec/cppcodec-0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
inherit cmake-utils

DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
HOMEPAGE="https://github.com/tplgy/cppcodec"

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/tplgy/cppcodec.git"

# Disable pulling in catch
EGIT_SUBMODULES=()
else
SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="MIT"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"

DEPEND="
test? (
virtual/pkgconfig
>=dev-cpp/catch-2.3.0
)"

src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
cmake-utils_src_configure
}

0 comments on commit 22369d8

Please sign in to comment.