Skip to content

Commit

Permalink
dev-ruby/tilt: add 2.0.3
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
graaff committed May 13, 2016
1 parent 1f6f689 commit 22517f7
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/tilt/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tilt-1.4.1.gem 42496 SHA256 39820562c4f5db45fe18de87ccc30a0e77a998bf5334b1d8c10a2f7dbc1f5903 SHA512 10fec263596d0e18a7a1440a7edfa08a161526cc46cc70427bc251951c447c40b4a4e8675e9162a9ed288879682b4aceeeb35b48cf3f4925921025194543363f WHIRLPOOL 5d70949358b97e867cdec160bd3c3726dabfec94bfeadc3a12f17463d378779d8502dda6458c7deb92bd3d9def91e306077ef806a7f75bd6c892554739ce46e9
DIST tilt-2.0.2.gem 48640 SHA256 04c91dcf7533576196e3ea2ba22514f37811ab7419bab6c71877e2e63a206d52 SHA512 93540d673f1c0e841be43e54e85451482f6ea8f967d14bce46c997be69a9ff16684aa5966c91cfd8d590cc32ef590974151183839ec315d46df5d398fd016832 WHIRLPOOL 051c29727ce157bf73d1c276c500471a48bde23a8a0ce516ad75e88a99b738e7c1a0283070db2c127922582e4f674e8591c69d36821744d5d09a3d0f9d0bd03f
DIST tilt-2.0.3.gem 51712 SHA256 4e68572c96e77f0dfcdc121958060a0d60a17a4be3fc7aca4a65b0500bc80c6a SHA512 762682dce36ff0e6614558dd3a8e2c81474f3c94c8a6330c8c17a773527ec410ca032f3a75af9189f82c16e8d803f0f16d76155aeaf8d4844543f1abf5efe7db WHIRLPOOL fdbe322c67bfd0c1224de8cefedf8733e684581d55ce93cedf39372b0ea73f698146c60aed7f95d1e3ca57439262006b237c6ca853c72878de6ce966f422eb23
49 changes: 49 additions & 0 deletions dev-ruby/tilt/tilt-2.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"

inherit ruby-fakegem

DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
HOMEPAGE="https://github.com/rtomayko/tilt"

LICENSE="MIT"
SLOT="2"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

# Block on some of the potential test dependencies. These dependencies
# are optional for the test suite, and we don't want to depend on all of
# them to faciliate keywording and stabling.
ruby_add_bdepend "test? (
dev-ruby/bluecloth
dev-ruby/coffee-script
dev-ruby/erubis
dev-ruby/nokogiri
!!<dev-ruby/maruku-0.7.2 )"

# Most dependencies are optional: skip haml and radius for ruby20 and ruby21
# because haml depends on rails.
USE_RUBY="ruby20 ruby21 ruby22" ruby_add_bdepend "test? ( dev-ruby/haml )"
USE_RUBY="ruby20 ruby21" ruby_add_bdepend "test? ( dev-ruby/radius )"

ruby_add_rdepend ">=dev-ruby/builder-2.0.0:*
!!<dev-ruby/tilt-1.4.1-r2:0"

all_ruby_prepare() {
rm Gemfile || die
sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die

# Avoid tests with minor syntax differences since this happens all
# the time when details in the dependencies change.
sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
#sed -i -e '/docbook templates/,/^ end/ s:^:#:' test/tilt_asciidoctor_test.rb || die
}

0 comments on commit 22517f7

Please sign in to comment.