Skip to content

Commit

Permalink
app-shells/mpibash: fix build with mpi-3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/656422
Closes: https://bugs.gentoo.org/708994
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Christoph Junghans <[email protected]>
  • Loading branch information
junghans committed Feb 19, 2020
1 parent 9cf2eab commit 2273e31
Show file tree
Hide file tree
Showing 5 changed files with 32 additions and 49 deletions.
1 change: 0 additions & 1 deletion app-shells/mpibash/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1 @@
DIST mpibash-1.2.tar.gz 347083 BLAKE2B 75b79d8e1f418de8220ff502245bc094774984f4760d922297a2ad2fcdb7d87a4a5d28015fd2686fbc68939ac532551046f8a987166accaa8b96025cce9fc79e SHA512 db755dd2c6212a8d7dfd6cbff17d5dffcbc3b6a0286abdad4d2e21790453d2356e88c566abe4648da138d6964098fad581b8fd5beae1335f5787de92f4659104
DIST mpibash-1.3.tar.gz 369803 BLAKE2B b1959deaa2d5b3bce1a66e5ef0ff41ad156093aec9cc1efcd12873b6d5814ad1586ff951d6fd7f37dab6a55040378774b435edc4e2c8892952480539864f91fa SHA512 4728565239aae80013322231a928fd1e9a59484614a92cf7e314d0cd5c090d3a47de395507ce52f71a6900245855089d659c6509f8c4df3bfd88e46fc2187749
24 changes: 24 additions & 0 deletions app-shells/mpibash/files/mpi-3.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
From 0b396b62ac314ae509ac3ca5fa9d5119e862be51 Mon Sep 17 00:00:00 2001
From: Scott Pakin <[email protected]>
Date: Wed, 19 Feb 2020 13:43:40 -0700
Subject: [PATCH] Replace deprecated MPI_Errhandler_set with newer
MPI_Comm_set_errhandler

Resolves #17.
---
src/init.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/init.c b/src/init.c
index cd070a7..46b1127 100644
--- a/src/init.c
+++ b/src/init.c
@@ -77,7 +77,7 @@ mpi_init_builtin (WORD_LIST *list)

/* Make MPI errors return instead of crash. Also, store our rank
* and number of ranks. */
- MPI_Errhandler_set (MPI_COMM_WORLD, MPI_ERRORS_RETURN);
+ MPI_Comm_set_errhandler (MPI_COMM_WORLD, MPI_ERRORS_RETURN);
MPI_Comm_rank (MPI_COMM_WORLD, &mpibash_rank);
MPI_Comm_size (MPI_COMM_WORLD, &mpibash_num_ranks);

42 changes: 0 additions & 42 deletions app-shells/mpibash/mpibash-1.2.ebuild

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=7

inherit autotools multilib

Expand All @@ -22,10 +22,12 @@ SLOT="0"
IUSE="examples"

DEPEND="virtual/mpi
>=app-shells/bash-4.2[plugins]
>=app-shells/bash-4.2:0[plugins]
sys-cluster/libcircle"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/mpi-3.patch" )

src_prepare() {
default
[[ ${PV} != 9999 ]] || eautoreconf
Expand Down
6 changes: 3 additions & 3 deletions app-shells/mpibash/mpibash-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=7

inherit autotools multilib

Expand All @@ -22,7 +22,7 @@ SLOT="0"
IUSE="examples"

DEPEND="virtual/mpi
>=app-shells/bash-4.2[plugins]
>=app-shells/bash-4.2:0[plugins]
sys-cluster/libcircle"
RDEPEND="${DEPEND}"

Expand Down

0 comments on commit 2273e31

Please sign in to comment.