Skip to content

Commit

Permalink
dev-python/pillow: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Jan 6, 2016
1 parent 63a3caa commit 227f00c
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pillow/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST Pillow-2.8.1.zip 9275663 SHA256 4363b52527c263e77f5b18c3dfffd15ae454edf0c44
DIST Pillow-2.8.2.zip 9402887 SHA256 57a900c2f30e53ed054adad401ab69643d9ab21e3acb0a647749a168e4e24446 SHA512 2bc1e17cb65d5e953e30ea1606dbf79059d51f60ff5c2b000869fc2d9f93f8bbf5cf41b0147fc83974c48341cc68df6964d3d8203e0d6cc6a45ede95f3e0bc2f WHIRLPOOL 4b5ad1db34427a161ce1885a858df72e4aaffd61b5bf9010702803874f44391678d228f71777fca058f424c6ac6208e8c3d7421eeff88c42bb6df94d1d13d771
DIST Pillow-2.9.0.zip 9612840 SHA256 d1db8dfed77547076037d589b598e04f2cbc1a7835d3d3f137bf20c8994854d5 SHA512 d06371fbe67eca66229cdec7896423f55c9335be50698168c7bf4f4635352454b2f946eae90b404c68d6b939ec1d7353916d32bc9964d5b8986b8098381d5180 WHIRLPOOL c664fec07c6634cad37791375fb1cb38b0edd542d93e099703dbc520e0d54125a1f00f205bbcdb8493df4dfd05ae1c2088ba305f23e66f0cc3e309f446c44fa5
DIST Pillow-3.0.0.zip 9947593 SHA256 0024fce578547a3da92579a163bae09b1d9f0baf3cd8e4a893dc6c11e4e624bb SHA512 59dd809160743d2740dfe64743dc674bb4cb6395914048d0d555ccacc7fee1c8f3a114ec39142b5495a0162a74acaadf7ad66694f97c7f221ccffe19cd656928 WHIRLPOOL 0fe2c9af2557278cc855ec7ddb4cfd944fbd1fc3cb2a614e84bd1dfa0c8ba243e60bda863b0b254098bcc7510d62953dbccf1fce88996011327f1059df0b69fb
DIST Pillow-3.1.0.zip 10077136 SHA256 d2cf322edab56fa5cf5400c96a2dbcf7062ef0ba7345ca4c2798be5595e16330 SHA512 4f9608ef7294a27dec78fbf8ea888ecaebea9199f4eb9167ff883b261f37ac4b01b3375e8c93567c9d6bbbacf80775fdd91abc8f0a7ef02528ba89ed858cce7d WHIRLPOOL 4a4eb8bd9a8356580033a39d31db5b86f54ee14f520c3b135ab1e6385730258481d558d28e9ad3b6257fe862508c8a385982b34791ba90da419e06f5657f700d
94 changes: 94 additions & 0 deletions dev-python/pillow/pillow-3.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
PYTHON_REQ_USE='tk?,threads(+)'

inherit distutils-r1 eutils virtualx

MY_PN=Pillow
MY_P=${MY_PN}-${PV}

DESCRIPTION="Python Imaging Library (fork)"
HOMEPAGE="https://github.com/python-imaging/Pillow https://pypi.python.org/pypi/Pillow"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"

LICENSE="HPND"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="doc examples jpeg jpeg2k lcms test tiff tk truetype webp zlib"

REQUIRED_USE="test? ( jpeg tiff )"

RDEPEND="
jpeg? ( virtual/jpeg:0 )
jpeg2k? ( media-libs/openjpeg:2= )
lcms? ( media-libs/lcms:2= )
tiff? ( media-libs/tiff:0= )
truetype? ( media-libs/freetype:2= )
webp? ( media-libs/libwebp:0= )
zlib? ( sys-libs/zlib:0= )"
DEPEND="${RDEPEND}
app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/sphinx-better-theme[${PYTHON_USEDEP}]
>=dev-python/sphinx_rtd_theme-0.1[${PYTHON_USEDEP}]
<dev-python/sphinx_rtd_theme-0.2[${PYTHON_USEDEP}]
)
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"

S="${WORKDIR}/${MY_P}"

# See _render and _clean in Tests/test_imagefont.py
DISTUTILS_IN_SOURCE_BUILD=1

python_prepare_all() {
# Disable all the stuff we don't want.
local f
for f in jpeg lcms tiff tk webp zlib; do
if ! use ${f}; then
sed -i -e "s:feature.${f} =:& None #:" setup.py || die
fi
done
if ! use truetype; then
sed -i -e 's:feature.freetype =:& None #:' setup.py || die
fi
if ! use jpeg2k; then
sed -i -e 's:feature.jpeg2000 =:& None #:' setup.py || die
fi

sed \
-e "/required/s:=.*:= set():g" \
-e "/if f in/s:'jpeg', 'libz'::g" \
-i setup.py || die

distutils-r1_python_prepare_all
}

python_compile_all() {
use doc && emake -C docs html
}

python_test() {
"${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
virtx nosetests -vx Tests/test_*.py
}

python_install() {
python_doheader libImaging/{Imaging.h,ImPlatform.h}

distutils-r1_python_install
}

python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
use examples && local EXAMPLES=( Scripts/. )

distutils-r1_python_install_all
}

0 comments on commit 227f00c

Please sign in to comment.