forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/xdis: Version bump, license change
Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST xdis-2.3.1.tar.gz 69207 SHA256 9b28426a5b476b6740b83063604de7ef4af8b721a5da5894145fbae8921d25ae SHA512 5015914a13296d04e71050c2e916fd5770bfe8bba1f92bf3c64bca06365ea7547cbb216d7cfca19fdcef60af3943fa4ba4e7c27895b1da9c6240daf990051927 WHIRLPOOL c30ae717289c73069efbdb70cdd6388bb009e945c967de53b159aa2f8a606cdca8e28b265b4da56b7f77ab01b8a415b8d8d8b7e1b972370121ab86b18d8921e7 | ||
DIST xdis-3.2.3.tar.gz 126710 SHA256 2e11b7dfafc02ce28da15f1d1bed327384ec34333d4a03e76cee8c1840897a5e SHA512 ce4e2ad09c1d13b2ab35b931ceedb8d08ec2f81dc2a34f50f854e6a4aca5efe857b56d6c2f1dbd73ae12d4ec9e2b0cc8e20c08873e87e4b0ca80fac229cebe06 WHIRLPOOL 1f553c3c57df5419b42ef6c94f7b78b5cbac14615d2d4066234420acd925b83df851332485a16ec8cace9ee5182b21b5bc1fc2fad7199ff4d6f17ce7de189cdb | ||
DIST xdis-3.2.4.tar.gz 127507 SHA256 b311253b97a321ab45625089a729ccbf8bcb1319a8c4c0167b719f81c081543c SHA512 6c9274e10f2a41ab4a173c8ae4462374fc7ab444a589ab572172550d0f5284906f7d9c9cf4a640f163f6012d17f40bc5e1c36e5963f8b6106a9c37e420027a97 WHIRLPOOL 5a0910f04e3d9ec70129d5d3b659fe06034e7a6298692d2a776f2616a8b895a539efa7f96972b2adc6986c2475e697552ea071d33bdd22c60bb1e0fec1950dd4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_{4,5} pypy) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Python cross-version byte-code disassembler and marshal routines" | ||
HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.python.org/pypi/xdis" | ||
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
>=dev-python/nose-1.0[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
python_prepare_all() { | ||
# Fix an unconditional test only dep | ||
sed \ | ||
-e "s/setup_requires/tests_require/" \ | ||
-i setup.py | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
# Need to rm any pyc files to prevent test failures. | ||
rm -R "${S}"/test/__pycache__ | ||
PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \ | ||
py.test -v || die "Tests failed under ${EPYTHON}" | ||
cd test | ||
PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \ | ||
${EPYTHON} test_pyenvlib.py --verify --simple --compile || die \ | ||
"Tests failed under ${EPYTHON}" | ||
} |