Skip to content

Commit

Permalink
dev-qt/qtmultimedia: revision bump to improve handling of EGL videono…
Browse files Browse the repository at this point in the history
…de plugin

ALso ensure Qt dependencies are of the same version.

Gentoo-bug: 564560
Gentoo-bug: 565588

Package-Manager: portage-2.2.26
  • Loading branch information
kensington committed Jan 14, 2016
1 parent 99430bf commit 2297fcb
Show file tree
Hide file tree
Showing 2 changed files with 79 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtmultimedia/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,6 +6,7 @@
<flag name="egl">Enable EGL integration</flag>
<flag name="exceptions">Add support for exceptions - like catching them
inside the event loop (recommended by upstream)</flag>
<flag name="gles2">Enable EGL/GLES2 integration</flag>
<flag name="gstreamer">Enable audio support via <pkg>media-libs/gstreamer:1.0</pkg></flag>
<flag name="gstreamer010">Enable audio support via <pkg>media-libs/gstreamer:0.10</pkg></flag>
<flag name="qml">Build QML/QtQuick bindings and imports</flag>
Expand Down
78 changes: 78 additions & 0 deletions dev-qt/qtmultimedia/qtmultimedia-5.5.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,78 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit qt5-build

DESCRIPTION="The Multimedia module for the Qt5 framework"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
fi

IUSE="alsa gles2 gstreamer gstreamer010 openal pulseaudio qml widgets"
REQUIRED_USE="?? ( gstreamer gstreamer010 )"

RDEPEND="
~dev-qt/qtcore-${PV}
~dev-qt/qtgui-${PV}
~dev-qt/qtnetwork-${PV}
alsa? ( media-libs/alsa-lib )
gstreamer? (
dev-libs/glib:2
media-libs/gstreamer:1.0
media-libs/gst-plugins-bad:1.0
media-libs/gst-plugins-base:1.0
)
gstreamer010? (
dev-libs/glib:2
media-libs/gstreamer:0.10
media-libs/gst-plugins-bad:0.10
media-libs/gst-plugins-base:0.10
)
pulseaudio? ( media-sound/pulseaudio )
qml? (
~dev-qt/qtdeclarative-${PV}
gles2? ( ~dev-qt/qtgui-${PV}[egl,gles2] )
!gles2? ( ~dev-qt/qtgui-${PV}[-egl] )
openal? ( media-libs/openal )
)
widgets? (
~dev-qt/qtopengl-${PV}
~dev-qt/qtwidgets-${PV}
)
"
DEPEND="${RDEPEND}
gstreamer? ( x11-proto/videoproto )
"

src_prepare() {
# do not rely on qtbase configuration
sed -i -e 's/contains(QT_CONFIG, \(alsa\|pulseaudio\))://' \
qtmultimedia.pro || die

qt_use_compile_test alsa
qt_use_compile_test gstreamer
qt_use_compile_test openal
qt_use_compile_test pulseaudio

qt_use_disable_mod qml quick \
src/src.pro \
src/plugins/plugins.pro

qt_use_disable_mod widgets widgets \
src/src.pro \
src/gsttools/gsttools.pro \
src/plugins/gstreamer/common.pri

qt5-build_src_prepare
}

src_configure() {
local myqmakeargs=(
$(usex gstreamer 'GST_VERSION=1.0' '')
$(usex gstreamer010 'GST_VERSION=0.10' '')
)
qt5-build_src_configure
}

0 comments on commit 2297fcb

Please sign in to comment.