forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/pycharm-professional: Version bump and stabilization (bug 61…
…0082). Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
50 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST pycharm-professional-2016.2.3.tar.gz 270995663 SHA256 a1eef156cc56eb3a36b437684b68b2e16f2575b5f1245a617eceb8352f6f4f5e SHA512 caffa429da22c49bff215777741ab3d9443e84f592bfee1120991dd116ee0523faf4bac8ffff9a3c3ae3f3ff25f94e8af7e108c0a320779b7028c9b7f40b6007 WHIRLPOOL 158ac76aa6ec01ecea3f7e69a1f39afe757018006f39b3ab9e3c69ceaff10b2f8129c0d31111d781c9cfbdad401feccd59139dd6ccdacfb00ed6fe18a5ed3c54 | ||
DIST pycharm-professional-2016.3.2.tar.gz 283150795 SHA256 c36413a56a8a1d046c84a2c32bab8aaba132551305a5db0845a6c7ed1dc0d4db SHA512 a189ae38a70874709b0e0243dc6a1dd14aa2b5199e8cf33a0f8c85dd0606e35ddb9d0f954ec9252da7a098cbe184bfa6bf69e43b7c8475c5c3776312f89395f7 WHIRLPOOL d8350fb6d1b4712f0082bca41b9ecf2f190bc5c95a72677efc9321abe7a9f5687c05f3554c7e7022e18e7d747f1a628acde8738012eb7e354d1801e374acbc53 |
49 changes: 49 additions & 0 deletions
49
dev-util/pycharm-professional/pycharm-professional-2016.3.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit eutils readme.gentoo-r1 | ||
|
||
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis" | ||
HOMEPAGE="http://www.jetbrains.com/pycharm/" | ||
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz" | ||
|
||
LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview" | ||
SLOT="0" | ||
KEYWORDS="amd64 x86" | ||
IUSE="" | ||
|
||
RDEPEND=">=virtual/jre-1.8 | ||
dev-python/pip" | ||
DEPEND="" | ||
|
||
RESTRICT="mirror strip" | ||
|
||
QA_PREBUILT="opt/${PN}/bin/fsnotifier | ||
opt/${PN}/bin/fsnotifier64 | ||
opt/${PN}/bin/fsnotifier-arm | ||
opt/${PN}/bin/libyjpagent-linux.so | ||
opt/${PN}/bin/libyjpagent-linux64.so" | ||
|
||
MY_PN=${PN/-professional/} | ||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
rm -rf jre || die | ||
} | ||
|
||
src_install() { | ||
insinto /opt/${PN} | ||
doins -r * | ||
|
||
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh} | ||
|
||
dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN} | ||
newicon "bin/${MY_PN}.png" ${PN}.png | ||
make_desktop_entry ${PN} "${PN}" "${PN}" | ||
|
||
readme.gentoo_create_doc | ||
} |