forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/apache-tools: bump to v2.4.41
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <[email protected]>
- Loading branch information
Showing
2 changed files
with
106 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST httpd-2.2.34.tar.bz2 5779739 BLAKE2B 8cdd41fb5d1880da4a1cfef252b4682f613b938594057ea4c9665d3881a50b298fb7339c1ceb3dafc215aa927048f99d500f2d29c125016d5766954be9b632b4 SHA512 e6dac5865a48533c025fe17523ee74d68c3a23f9512c9441b78a140e33cfb6835573eb049b0ad424eb5c5ca78a1915778c54e8a409da95fbdd3890cb99e08240 | ||
DIST httpd-2.4.39.tar.bz2 7030539 BLAKE2B 1e378833efb9bbdd6fdc277a779620a08752d064524489f9ad747cf85350fbb6ad65f57b30c81d57273cd6693d8a2c4e988f5a2c42bd5c9c538b305b9b7719e8 SHA512 9742202040b3dc6344b301540f54b2d3f8e36898410d24206a7f8dcecb1bea7d7230fabc7256752724558af249facf64bffe2cf678b8f7cccb64076737abfda7 | ||
DIST httpd-2.4.41.tar.bz2 7072373 BLAKE2B 88a2390736209d5ef04bffcb867bc8d6019302885e6f3cc63d18123336d4d0657252105a3bfebf4e91b8daa02119d4a61f4c0a9702244858a3193ec6cf681c0f SHA512 350cc7dcd2c439e0590338fa6da3f44df44f9bb885c381e91f91b14c2f48597f6f0bbac0ea118a8a67eaa70ae7edbb769beace368643ed73f6daee44c307b335 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,105 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit flag-o-matic eutils multilib toolchain-funcs | ||
|
||
DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm" | ||
HOMEPAGE="https://httpd.apache.org/" | ||
SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris" | ||
IUSE="libressl ssl" | ||
RESTRICT="test" | ||
|
||
RDEPEND=">=dev-libs/apr-1.5.0:1= | ||
dev-libs/apr-util:1= | ||
dev-libs/expat | ||
dev-libs/libpcre | ||
kernel_linux? ( sys-apps/util-linux ) | ||
ssl? ( | ||
!libressl? ( dev-libs/openssl:0= ) | ||
libressl? ( dev-libs/libressl:0= ) | ||
)" | ||
|
||
DEPEND="${RDEPEND} | ||
sys-devel/libtool" | ||
|
||
S="${WORKDIR}/httpd-${PV}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.4.7-Makefile.patch" #459446 | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
# This package really should upgrade to using pcre's .pc file. | ||
cat <<-\EOF >"${T}"/pcre-config | ||
#!/bin/bash | ||
flags=() | ||
for flag; do | ||
if [[ ${flag} == "--version" ]]; then | ||
flags+=( --modversion ) | ||
else | ||
flags+=( "${flag}" ) | ||
fi | ||
done | ||
exec ${PKG_CONFIG} libpcre "${flags[@]}" | ||
EOF | ||
chmod a+x "${T}"/pcre-config || die | ||
} | ||
|
||
src_configure() { | ||
# Brain dead check. | ||
tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no" | ||
|
||
tc-export PKG_CONFIG | ||
|
||
local myeconfargs=( | ||
--libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules | ||
--sbindir="${EPREFIX}"/usr/sbin | ||
--with-perl="${EPREFIX}"/usr/bin/perl | ||
--with-expat="${EPREFIX}"/usr | ||
--with-z="${EPREFIX}"/usr | ||
--with-apr="${SYSROOT}${EPREFIX}"/usr | ||
--with-apr-util="${SYSROOT}${EPREFIX}"/usr | ||
--with-pcre="${T}"/pcre-config | ||
$(use_enable ssl) | ||
$(usex ssl '--with-ssl="${EPREFIX}"/usr' '') | ||
) | ||
# econf overwrites the stuff from config.layout. | ||
ac_cv_path_PKGCONFIG=${PKG_CONFIG} \ | ||
econf "${myeconfargs[@]}" | ||
sed -i \ | ||
-e '/^LTFLAGS/s:--silent::' \ | ||
build/rules.mk build/config_vars.mk || die | ||
} | ||
|
||
src_compile() { | ||
emake -C support | ||
} | ||
|
||
src_install() { | ||
emake -C support DESTDIR="${D}" install | ||
dodoc CHANGES | ||
doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \ | ||
docs/man/{htcacheclean,rotatelogs}.8 | ||
|
||
# Providing compatiblity symlinks for #177697 (which we'll stop to install | ||
# at some point). | ||
pushd "${ED%/}"/usr/sbin >/dev/null || die | ||
local i | ||
for i in *; do | ||
dosym ${i} /usr/sbin/${i}2 | ||
done | ||
popd >/dev/null || die | ||
|
||
# Provide a symlink for ab-ssl | ||
if use ssl ; then | ||
dosym ab /usr/bin/ab-ssl | ||
dosym ab /usr/bin/ab2-ssl | ||
fi | ||
} |