Skip to content

Commit

Permalink
app-emulation/docker-proxy: Update snapshot for docker 18.02.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
mrueg committed Feb 9, 2018
1 parent 95c9943 commit 2310628
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/docker-proxy/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST docker-proxy-0.8.0_p20161111.tar.gz 2150464 BLAKE2B a752ad0170cab2aebe2d5e826db22f5e21135a8fbfa835f62804c303be9f136fee941942e7d07e82e19033a62d51f37a41e9c36b48df48947d2885c351584f4f SHA512 86293b9cafc3c468760266b47412040f21309baad27765f584cfa1e93bc2ad88068832ed55f2ae8e4f16825e9f44619e89985fd36d98b3d47eaf1d1160f76c8e
DIST docker-proxy-0.8.0_p20170917.tar.gz 2177045 BLAKE2B 0fed1328e8216ab83b23e8e1fe1793da6e874eced7ad18d101b0b7757f1de4fa7d321fb78620a349a4ed492abb4d85c3ecbf49311698b6af156a6255dec5740e SHA512 673ea638fa5c560d8238d7c1d88f114430f9d8efe701804bfe30044d0c059a688cbf6b62922be50834e16ee055ef6cf015f6232f76f0d942768f9e84e95496cd
DIST docker-proxy-0.8.0_p20180112.tar.gz 2679651 BLAKE2B aa134607a90029b41f12885876f175e0e4d77de7e23888912e561d2a75056a8b85f8bb31bfc27e5ddcb102d7d113720ecf4796d7c7d6f6a4c5db10c5f4c60915 SHA512 43d7a8259b5ee2f605ae07dfe64e25b90445b9d38b279a19366df64093dc7d16f3820e3cd67c8569292efc548334a278f1fcbcfb13aed3a73ba980309f8115c9
36 changes: 36 additions & 0 deletions app-emulation/docker-proxy/docker-proxy-0.8.0_p20180112.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EGO_PN="github.com/docker/libnetwork"

if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
EGIT_COMMIT="fcf1c3b5e57833aaaa756ae3c4140ea54da00319"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc64"
inherit golang-vcs-snapshot
fi

DESCRIPTION="Docker container networking"
HOMEPAGE="https://github.com/docker/libnetwork"

LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

S=${WORKDIR}/${P}/src/${EGO_PN}

RDEPEND="!<app-emulation/docker-1.13.0_rc1"

RESTRICT="test" # needs dockerd

src_compile() {
GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
}

src_install() {
dodoc ROADMAP.md README.md CHANGELOG.md
dobin bin/docker-proxy
}

0 comments on commit 2310628

Please sign in to comment.