Skip to content

Commit

Permalink
kde-frameworks/baloo: Backport fix for baloo crash if disabled
Browse files Browse the repository at this point in the history
Upstream bug: https://bugs.kde.org/show_bug.cgi?id=353049

Package-Manager: portage-2.2.20.1
  • Loading branch information
a17r authored and Michael Palimaka committed Sep 26, 2015
1 parent a5fa7a7 commit 233ee64
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
36 changes: 36 additions & 0 deletions kde-frameworks/baloo/baloo-5.14.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_PUNT_BOGUS_DEPS="true"
inherit kde5

DESCRIPTION="Framework for searching and managing metadata"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="
$(add_frameworks_dep kauth)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kfilemetadata)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kidletime)
$(add_frameworks_dep kio)
$(add_frameworks_dep solid)
dev-db/lmdb
dev-qt/qtdbus:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
sys-apps/attr
"
RDEPEND="${DEPEND}
!kde-base/baloo:4[-minimal(-)]
"

PATCHES=( "${FILESDIR}/${P}-check-if-db-open.patch" )
28 changes: 28 additions & 0 deletions kde-frameworks/baloo/files/baloo-5.14.0-check-if-db-open.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
From: Boudhayan Gupta <[email protected]>
Date: Tue, 22 Sep 2015 18:55:36 +0000
Subject: Fail Baloo::File::load() if the Database is not open.
X-Git-Url: http://quickgit.kde.org/?p=baloo.git&a=commitdiff&h=29fe68f2657df503926e629477a41f7d9435048f
---
Fail Baloo::File::load() if the Database is not open.
Fixes crash if selecting multiple files in Dolphin with
Baloo disabled.

BUG: 353049
REVIEW: 125352
---


--- a/src/lib/file.cpp
+++ b/src/lib/file.cpp
@@ -98,6 +98,10 @@
Database *db = globalDatabaseInstance();
db->open(Database::OpenDatabase);

+ if (!db->isOpen()) {
+ return false;
+ }
+
quint64 id = filePathToId(QFile::encodeName(d->url));
if (!id) {
return false;

0 comments on commit 233ee64

Please sign in to comment.