Skip to content

Commit

Permalink
app-crypt/rhash: Version bump to 1.3.6, new build system
Browse files Browse the repository at this point in the history
The static Makefiles are now complemented with a hand-written
configure script. :| On the plus side, it does at least deal with all
the portability issues we had to hack around before.

Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
chewi committed Mar 18, 2018
1 parent 8160e61 commit 2350d67
Show file tree
Hide file tree
Showing 3 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/rhash/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rhash-1.3.5-src.tar.gz 316867 BLAKE2B 3ffbf2ec5aef24ef63455e21c3efcae043a321a78be522a26bd25086111430071a496ab3775ff9b4956da7304df8d8e552a061f3306a7a683be5fc65ea3fd1c4 SHA512 e8450aab0c16bfb975bf4aeee218740fb4d86d5514e426b70c3edb84e4d63865cd4051939aa95c24a87a78baaedc49e40bb509b2610e89ca3745930808b3ef6c
DIST rhash-1.3.6-src.tar.gz 328097 BLAKE2B c74993d183f0f2e479f0bd5831a9f653b9bd17bbed4d1ba896f6e33db98b7141175cd3c688dc41dfd8ec4b98acb51255ae5b795435cbc9dfb5ab77573cb25543 SHA512 54f7f238ed1fdc01c29cc1338fa86be90b69beff0df8f20d24ce9cb3c48c7f4668b84a3fe0d4d8b04b54bc8145485d493435edf3219de3a637af0f9c007c85c6
26 changes: 26 additions & 0 deletions app-crypt/rhash/files/unquote-cc.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 4558d6753611ab1bf21765017e5b451aee8409f6 Mon Sep 17 00:00:00 2001
From: James Le Cuirot <[email protected]>
Date: Sun, 18 Mar 2018 14:23:28 +0000
Subject: [PATCH] configure: Don't quote $CC when calling it

It might have additional arguments.
---
configure | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure b/configure
index f480f7b..8ebb929 100755
--- a/configure
+++ b/configure
@@ -480,7 +480,7 @@ if test "$(basename $CC)" = "icc" || test "$(basename $CC)" = "ecc"; then
else
CC_TMP="$CC"
for CC in "$CC_TMP" gcc cc ; do
- if "$CC" -v >/dev/null 2>&1; then
+ if $CC -v >/dev/null 2>&1; then
cc_name_tmp=$($CC -v 2>&1 | tail -n 1 | cut -d ' ' -f 1)
if test "$cc_name_tmp" = "gcc"; then
cc_name=$cc_name_tmp
--
2.16.1

67 changes: 67 additions & 0 deletions app-crypt/rhash/rhash-1.3.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs multilib-minimal

DESCRIPTION="Console utility and library for computing and verifying file hash sums"
HOMEPAGE="http://rhash.anz.ru/"
SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="debug nls openssl static-libs"

RDEPEND="openssl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )"

DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"

S="${WORKDIR}/RHash-${PV}"

PATCHES=(
"${FILESDIR}"/unquote-cc.patch
)

src_prepare() {
default
multilib_copy_sources
}

multilib_src_configure() {
set -- \
./configure \
--cc="$(tc-getCC)" \
--ar="$(tc-getAR)" \
--extra-cflags="${CFLAGS}" \
--extra-ldflags="${LDFLAGS}" \
--prefix="${EPREFIX}"/usr \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--sysconfdir="${EPREFIX}"/etc \
--disable-openssl-runtime \
--disable-static \
--enable-lib-shared \
$(use_enable debug) \
$(use_enable nls gettext) \
$(use_enable openssl) \
$(use_enable static-libs lib-static)

echo "${@}"
"${@}" || die "configure failed"
}

# We would add compile-gmo to the build targets but install-gmo always
# recompiles unconditionally. :(

multilib_src_install() {
# -j1 needed due to race condition.
emake DESTDIR="${D}" -j1 \
install{,-lib-so-link,-pkg-config} \
$(use nls && echo install-gmo)
}

multilib_src_test() {
emake test
}

0 comments on commit 2350d67

Please sign in to comment.