Skip to content

Commit

Permalink
media-gfx/sane-backends: security bump to 1.0.30
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/691204
Bug: https://bugs.gentoo.org/729312
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sam James (sam_c) <[email protected]>
Closes: gentoo#16384
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
thesamesam authored and Whissi committed Jun 26, 2020
1 parent 6f06af2 commit 2359950
Show file tree
Hide file tree
Showing 3 changed files with 359 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-gfx/sane-backends/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST backends-1.0.30.tar.gz 5721262 BLAKE2B 139d3ca908d54b94d14ef4145d44a89b939807c15870be03c3c028cf95351bf9a4abd3ea115b84396366bb054f37ade883f429467dceb0663c2855b92e0a4fa5 SHA512 19127c8109c1587d60d8cba713f73b1a24242df44fa49c3e59320f48022783f05d26d3242a3f87478e583a807d88b446ef7a51afb33b674be29656496c435d7b
DIST sane-backends-1.0.27.tar.gz 6430188 BLAKE2B 90f910311e31a436eaa0ca0fedd998aac3331f89a346f31613776ebc860a10cc37055fd15db8de8d743498914ea0c16e4153dbaa101380eb6e36857d730c3456 SHA512 c6552768bfc10216730fc11011c82f74ca0952182019ded3916072147ec09be5c975ce1d37dc3ccea050c488dbdf983c2ca17dcd702644060ba796ae2591f9c5
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
https://gitlab.com/sane-project/backends/-/issues/314
https://gitlab.com/sane-project/backends/-/commit/6bb87fdf1f3dc190cfc4b7d64b0c8c8c3d10151b.diff
--- a/sanei/sanei_usb.c
+++ b/sanei/sanei_usb.c
@@ -48,6 +48,9 @@

#include "../include/sane/config.h"

+#ifdef HAVE_STDINT_H
+# include <stdint.h>
+#endif
#include <stdlib.h>
#include <ctype.h>
#include <sys/types.h>
344 changes: 344 additions & 0 deletions media-gfx/sane-backends/sane-backends-1.0.30.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,344 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools eutils flag-o-matic multilib-minimal systemd toolchain-funcs udev user

# gphoto and v4l are handled by their usual USE flags.
# The pint backend was disabled because I could not get it to compile.
IUSE_SANE_BACKENDS="
abaton
agfafocus
apple
artec
artec_eplus48u
as6e
avision
bh
canon
canon630u
canon_dr
canon_pp
cardscan
coolscan
coolscan2
coolscan3
dc210
dc240
dc25
dell1600n_net
dmc
epjitsu
epson
epson2
fujitsu
genesys
gt68xx
hp
hp3500
hp3900
hp4200
hp5400
hp5590
hpljm1005
hpsj5s
hs2p
ibm
kodak
kodakaio
kvs1025
kvs20xx
kvs40xx
leo
lexmark
ma1509
magicolor
matsushita
microtek
microtek2
mustek
mustek_pp
mustek_usb
mustek_usb2
nec
net
niash
p5
pie
pixma
plustek
plustek_pp
pnm
qcam
ricoh
rts8891
s9036
sceptre
sharp
sm3600
sm3840
snapscan
sp15c
st400
stv680
tamarack
teco1
teco2
teco3
test
u12
umax
umax1220u
umax_pp
xerox_mfp"

IUSE="gphoto2 ipv6 snmp systemd threads usb v4l xinetd zeroconf"

for backend in ${IUSE_SANE_BACKENDS}; do
case ${backend} in
# Disable backends that require parallel ports as no one has those anymore.
canon_pp|hpsj5s|mustek_pp|\
pnm)
IUSE+=" -sane_backends_${backend}"
;;
mustek_usb2|kvs40xx)
IUSE+=" sane_backends_${backend}"
;;
*)
IUSE+=" +sane_backends_${backend}"
esac
done

REQUIRED_USE="
sane_backends_mustek_usb2? ( threads )
sane_backends_kvs40xx? ( threads )
"

MY_PN=${PN//sane-/}
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Scanner Access Now Easy - Backends"
HOMEPAGE="http://www.sane-project.org/"
SRC_URI="https://gitlab.com/sane-project/${MY_PN}/-/archive/${PV}/${MY_P}.tar.gz"

LICENSE="GPL-2 public-domain"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
sane_backends_dc210? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
sane_backends_dc240? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
sane_backends_dell1600n_net? (
>=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}]
>=media-libs/tiff-3.9.7-r1:0=[${MULTILIB_USEDEP}]
)
sane_backends_canon_pp? ( >=sys-libs/libieee1284-0.2.11-r3[${MULTILIB_USEDEP}] )
sane_backends_hpsj5s? ( >=sys-libs/libieee1284-0.2.11-r3[${MULTILIB_USEDEP}] )
sane_backends_mustek_pp? ( >=sys-libs/libieee1284-0.2.11-r3[${MULTILIB_USEDEP}] )
usb? ( >=virtual/libusb-1-r1:1=[${MULTILIB_USEDEP}] )
gphoto2? (
>=media-libs/libgphoto2-2.5.3.1:=[${MULTILIB_USEDEP}]
>=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}]
)
v4l? ( >=media-libs/libv4l-0.9.5[${MULTILIB_USEDEP}] )
xinetd? ( sys-apps/xinetd )
snmp? ( net-analyzer/net-snmp:0= )
systemd? ( sys-apps/systemd:0= )
zeroconf? ( >=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}] )
"

DEPEND="${RDEPEND}
v4l? ( sys-kernel/linux-headers )
>=sys-devel/gettext-0.18.1
virtual/pkgconfig
"

PATCHES=(
"${FILESDIR}"/${PN}-1.0.24-saned_pidfile_location.patch
"${FILESDIR}"/${PN}-1.0.27-disable-usb-tests.patch
"${FILESDIR}"/${P}-missing-stdint-include.patch
)

S="${WORKDIR}/${MY_P}"

MULTILIB_CHOST_TOOLS=(
/usr/bin/sane-config
)

pkg_setup() {
enewgroup scanner
enewuser saned -1 -1 -1 scanner
}

src_prepare() {
default

cat >> backend/dll.conf.in <<-EOF
# Add support for the HP-specific backend. Needs net-print/hplip installed.
hpaio
# Add support for the Epson-specific backend. Needs media-gfx/iscan installed.
epkowa
EOF

# Patch out the git reference so we can run eautoreconf
sed -i -e "s/m4_esyscmd_s(\[git describe --dirty\])/${PV}/" configure.ac || die
eautoreconf

# Fix for "make check". Upstream sometimes forgets to update this.
local ver=$(./configure --version | awk '{print $NF; exit 0}')
sed -i \
-e "/by sane-desc 3.5 from sane-backends/s:sane-backends .*:sane-backends ${ver}:" \
testsuite/tools/data/html* || die

}

src_configure() {
append-flags -fno-strict-aliasing # From Fedora

# if LINGUAS is set, just use the listed and supported localizations.
if [[ ${LINGUAS+set} == "set" ]]; then
mkdir -p po || die
strip-linguas -u po
printf '%s\n' ${LINGUAS} > po/LINGUAS
fi

multilib-minimal_src_configure
}

multilib_src_configure() {
# the blank is intended - an empty string would result in building ALL backends.
local BACKENDS=" "

use gphoto2 && BACKENDS="gphoto2"
use v4l && BACKENDS="${BACKENDS} v4l"
for backend in ${IUSE_SANE_BACKENDS}; do
if use "sane_backends_${backend}" && [ ${backend} != pnm ]; then
BACKENDS="${BACKENDS} ${backend}"
fi
done

local myconf=(
$(use_with usb)
$(multilib_native_use_with snmp)
)

# you can only enable this backend, not disable it...
if use sane_backends_pnm; then
myconf+=( --enable-pnm-backend )
fi
if use sane_backends_mustek_pp; then
myconf+=( --enable-parport-directio )
fi
if ! { use sane_backends_canon_pp || use sane_backends_hpsj5s || use sane_backends_mustek_pp; }; then
myconf+=( sane_cv_use_libieee1284=no )
fi

# relative path must be used for tests to work properly
# All distributions pass --disable-locking because /var/lock/sane/ would be a world-writable directory
# --without-api-spec to not automagically depend on tons of stuff
# that break in many ways, bug #636202, #668232, #668350
# People can refer to the "Programmer's Documentation" at http://www.sane-project.org/docs.html
ECONF_SOURCE=${S} \
SANEI_JPEG="sanei_jpeg.o" SANEI_JPEG_LO="sanei_jpeg.lo" \
BACKENDS="${BACKENDS}" \
econf \
--disable-locking \
--without-api-spec \
$(use_with gphoto2) \
$(multilib_native_use_with systemd) \
$(use_with v4l) \
$(use_enable ipv6) \
$(use_enable threads pthread) \
$(use_enable zeroconf avahi) \
"${myconf[@]}"
}

multilib_src_compile() {
emake VARTEXFONTS="${T}/fonts"

if tc-is-cross-compiler; then
pushd "${BUILD_DIR}"/tools >/dev/null || die

# The build system sucks and doesn't handle this properly.
# https://alioth.debian.org/tracker/index.php?func=detail&aid=314236&group_id=30186&atid=410366
tc-export_build_env BUILD_CC
${BUILD_CC} ${BUILD_CPPFLAGS} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
-I. -I../include -I"${S}"/include \
"${S}"/sanei/sanei_config.c "${S}"/sanei/sanei_constrain_value.c \
"${S}"/sanei/sanei_init_debug.c "${S}"/tools/sane-desc.c -o sane-desc || die
local dirs=( hal hotplug hotplug-ng udev )
local targets=(
hal/libsane.fdi
hotplug/libsane.usermap
hotplug-ng/libsane.db
udev/libsane.rules
)
mkdir -p "${dirs[@]}" || die
emake "${targets[@]}"

popd >/dev/null
fi

if use usb; then
sed -i -e '/^$/d' \
tools/hotplug/libsane.usermap || die
fi
}

multilib_src_install() {
emake INSTALL_LOCKPATH="" DESTDIR="${D}" install \
docdir="${EPREFIX}"/usr/share/doc/${PF}

if multilib_is_native_abi; then
if use usb; then
insinto /etc/hotplug/usb
doins tools/hotplug/libsane.usermap
fi

udev_newrules tools/udev/libsane.rules 41-libsane.rules
insinto "/usr/share/pkgconfig"
doins tools/sane-backends.pc
fi
}

multilib_src_install_all() {
keepdir /var/lib/lock/sane
fowners root:scanner /var/lib/lock/sane
fperms g+w /var/lib/lock/sane
dodir /etc/env.d

if use systemd; then
systemd_newunit "${FILESDIR}"/saned_at.service "[email protected]"
systemd_newunit "${FILESDIR}"/saned.socket saned.socket
fi

if use usb; then
exeinto /etc/hotplug/usb
doexe tools/hotplug/libusbscanner
newdoc tools/hotplug/README README.hotplug
fi

dodoc NEWS AUTHORS PROBLEMS README README.linux
find "${D}" -name '*.la' -delete || die

if use xinetd; then
insinto /etc/xinetd.d
doins "${FILESDIR}"/saned
fi

newinitd "${FILESDIR}"/saned.initd saned
newconfd "${FILESDIR}"/saned.confd saned
}

pkg_postinst() {
if use xinetd; then
elog "If you want remote clients to connect, edit"
elog "/etc/sane.d/saned.conf and /etc/hosts.allow"
fi

if ! use systemd; then
elog "If you are using a USB scanner, add all users who want"
elog "to access your scanner to the \"scanner\" group."
fi
}

0 comments on commit 2359950

Please sign in to comment.