Skip to content

Commit

Permalink
sys-cluster/libquo: import live ebuild for sci overlay
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
junghans committed Jan 16, 2017
1 parent e1ead1f commit 23ab613
Showing 1 changed file with 42 additions and 0 deletions.
42 changes: 42 additions & 0 deletions sys-cluster/libquo/libquo-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

FORTRAN_NEEDED=fortran
FORTRAN_STANDARD=90

inherit fortran-2

if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="git://github.com/lanl/${PN}.git https://github.com/lanl/${PN}.git"
inherit autotools git-r3
KEYWORDS=""
else
SRC_URI="http://lanl.github.io/${PN}/dists/${P}.tar.gz"
KEYWORDS="~amd64"
fi

DESCRIPTION="run-time tuning of process binding policies made easy"
HOMEPAGE="http://lanl.github.io/libquo/"

LICENSE="BSD"
SLOT="0"
IUSE="fortran static-libs test"

DEPEND="
virtual/mpi[fortran?]
sys-process/numactl
sys-apps/hwloc[numa,xml]
"
RDEPEND="${DEPEND}"

src_prepare() {
default
[[ ${PV} = 9999 ]] && eautoreconf
}

src_configure() {
econf CC=mpicc FC=$(usex fortran mpif90 false)
}

0 comments on commit 23ab613

Please sign in to comment.