forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
2 changed files
with
52 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST apache-libcloud-0.14.1.tar.bz2 546545 SHA256 8562fd79c8afc63dabc8f62b08f13a1b1f71644c08e47f913f8c942d2f48c1d0 SHA512 cb338e63aa1b3949ac16eee77df53499797c92ea9e30dccb2ed0c823636f8adda62673131c25bc5138839da2b7a3a8c895d0acaadeff087c756e43b9ae23f5d9 WHIRLPOOL 7e3d5991487ceb3312d46b54bb7e525431c611d003d19c3f05ef4261257127622f0787d55fe08dfd1b0419cc85820ad3c2d1d8f3228aa31e475f4242a1452be0 | ||
DIST apache-libcloud-0.15.0.tar.bz2 571365 SHA256 fcfea13c73279aaa846bbc6a22dad37864b2314b8497a3a4994b2b0632cf0633 SHA512 b0e85dba0a70701784903510e6eed1ada082b02e989a6af43122e3eaaaeee1cbd5da59660e1e78877219798b50f395d02d0738ae983bd1665eba0984d737e16c WHIRLPOOL eae1dd98b931ea88431d34b18325a3f62ab076d52fbeedc9ee9507234133fc1d99eed4cd24a3411e50870008aad3233f5d715341e3c2444aac29c6c3e35299ed | ||
DIST apache-libcloud-0.15.1.tar.bz2 570953 SHA256 557e3f29e0ab1f19a31e858a8e802c822cb7f07df5edce029a1c67d2b0f30d15 SHA512 0cbc02c955cb91e135d73a5198ad216d0f91fa942b88dd1ffc1c46a487190f45500f003d2825cdb4f6c96c4ca7e5cf2681709769b0c2d8801b08e5a41b3d69b0 WHIRLPOOL 0143a7d2c337603f769bb2d3fd4fb98df18c82dfaa09c12fe481f18eb300c65d9efd4e18756d0c75a691b6d755fff0f62d41ccda3c9006955870fb8631d8366d | ||
DIST apache-libcloud-0.17.0.tar.bz2 663406 SHA256 22a6360fccbd956398e3236dceacc469c397d0d8c0caad33352f224b352bd943 SHA512 a87d60362c43e3a1f1a4534641985d81b07ff8ad5029cd04b446fcb30cd3373471c86f62aeed75c98cbbe61d59aece50b2e8deead755535b609847ee60ce8027 WHIRLPOOL 727f0c5c2542a5357d20e587e005f7017754e6214646af170ec639c737325be0e5bbf9215d9b35ad3cc43f9edf3ecdabc93fb1907bfeff49f7fdd1073a606d27 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
# py3 dropped due to failing tests once lockfile installed | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy ) | ||
PYTHON_REQ_USE="ssl(+)" | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Unified Interface to the Cloud - python support libs" | ||
HOMEPAGE="http://libcloud.apache.org/index.html" | ||
SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="examples test" | ||
|
||
RDEPEND="" | ||
DEPEND="test? ( | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/lockfile[${PYTHON_USEDEP}] | ||
$(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python{2_7,3_4} pypy) | ||
)" | ||
|
||
S="${WORKDIR}/apache-${P}" | ||
|
||
python_prepare_all() { | ||
if use examples; then | ||
mkdir examples | ||
mv example_*.py examples || die | ||
fi | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
src_test() { | ||
cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die | ||
distutils-r1_src_test | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} | ||
|
||
python_install_all() { | ||
use examples && local EXAMPLES=( examples/. ) | ||
distutils-r1_python_install_all | ||
} |