Skip to content

Commit

Permalink
sci-visualization/gcalc: EAPI bump 4 -> 6
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
Closes: gentoo#3471
  • Loading branch information
g-braeunlich authored and chewi committed Jan 15, 2017
1 parent 5f34df4 commit 24218db
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions sci-visualization/gcalc/gcalc-3.1_rc1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils java-pkg-2 java-pkg-simple

MY_P="GCalc-${PV/_/-}"
DESCRIPTION="Java Mathematical Graphing System"
HOMEPAGE="http://gcalc.net/"
SRC_URI="http://gcalc.net/files/${MY_P}.tar.gz"

LICENSE="GPL-2"
KEYWORDS="~amd64"
IUSE=""
SLOT="0"

RDEPEND=">=virtual/jre-1.7
!!sci-mathematics/gcalc"
DEPEND=">=virtual/jdk-1.7"

S="${WORKDIR}/${MY_P}"

src_prepare() {
java-pkg_clean
default
}

src_compile() {
java-pkg-simple_src_compile
java-pkg_addres ${PN}.jar src ! -name "*.html"
}

src_install() {
java-pkg-simple_src_install
java-pkg_dolauncher gcalc --main net.gcalc.calc.GCalc

newicon src/resources/gicon.png ${PN}.png
make_desktop_entry ${PN} "GCalc Java Mathematical Graphing System"
}

0 comments on commit 24218db

Please sign in to comment.