Skip to content

Commit

Permalink
dev-python/brython: convert ebuild to python-single-r1.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.1
  • Loading branch information
monsieurp committed Sep 27, 2017
1 parent 329b785 commit 244899e
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions dev-python/brython/brython-3.3.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit webapp python-single-r1

DESCRIPTION="A Python 3 implementation for client-side web programming"
HOMEPAGE="http://www.brython.info"
SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.zip -> ${P}.zip"

LICENSE="BSD"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

need_httpd_cgi

pkg_setup() {
webapp_pkg_setup
python-single-r1_pkg_setup
}

src_install() {
dodoc LICENCE.txt README.md
rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die

webapp_src_preinst

insinto "${MY_HTDOCSDIR}"
doins -r .

webapp_src_install
}

0 comments on commit 244899e

Please sign in to comment.