Skip to content

Commit

Permalink
app-eselect/eselect-repository: Bump to v4
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Jun 2, 2018
1 parent bb1fa88 commit 24b6098
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-eselect/eselect-repository/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST eselect-repository-3.tar.gz 5448 BLAKE2B 36a079f2a876709a2cc045e0c113f44f9feaa491c49d3773eb3e123ee7e7a7ffa2ad05060ffa62ac39ff8091a64ff995ea948f3c784ffbb7d8ddca5e468364d3 SHA512 ac3396a6d14fcc7d4df1f9b058bc3025875707f3febdf4d1e03122445d0e6273759b8a66443525c94daaf19f91b411c469aabc0e0082cd53980886a91f38a062
DIST eselect-repository-4.tar.gz 5535 BLAKE2B 4dce6c0136ec9394c9bf4128ec26ab67260d4b96a165825ae7b15b8476d10d23fcc5190946fc54013d6eb8e4f18988b07df4c849ba50844571986a6823511547 SHA512 0d3c204d73bb4314bc24fdf6cd837f2a56ac00d1d11fbec7f072af874bc468777676bba40e0cc17553f6dec7a907f10865f9c356a6390372e0734173465ac483
40 changes: 40 additions & 0 deletions app-eselect/eselect-repository/eselect-repository-4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{3_4,3_5,3_6} )
inherit python-single-r1

DESCRIPTION="Manage repos.conf via eselect"
HOMEPAGE="https://github.com/mgorny/eselect-repository"
SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
REQUIRED_USE=${PYTHON_REQUIRED_USE}

RDEPEND="${PYTHON_DEPS}
app-admin/eselect
dev-python/lxml[${PYTHON_USEDEP}]
net-misc/wget"

src_compile() {
MAKEARGS=(
PREFIX="${EPREFIX}/usr"
SYSCONFDIR="${EPREFIX}/etc"
SHAREDSTATEDIR="${EPREFIX}/var"
ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
)

emake "${MAKEARGS[@]}"
python_fix_shebang eselect-repo-helper
}

src_install() {
emake "${MAKEARGS[@]}" DESTDIR="${D}" install
keepdir /var/db/repos
einstalldocs
}

0 comments on commit 24b6098

Please sign in to comment.