forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
- Loading branch information
Showing
2 changed files
with
45 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST autopep8-1.3.2.tar.gz 107915 BLAKE2B 3148f12616babc26415fc138d5d9e2d2a83cc735449cea54870662dabdfebfd298d96ca716ee62c9143049a2abf05e6a597b0ec6bab90c557dae63999794ea25 SHA512 cb9a5e297ce705722d5e65472dbe749e57fa12fe8dee0d4c3dc20d9e885e0d885339627667110318c89c6bf7e337203a7831c0e2217e5a5d7951edcb98d3df4f | ||
DIST autopep8-1.3.3.tar.gz 108639 BLAKE2B d2e6f6f334dfeb5e8ae33f4460c9344ec6b1e234e7f714c7602fae72f1ca5608e12145c40a39b14d28e1d79b0dd91855493d87947407428ba4c1d87834156626 SHA512 e327d58311f74c8bb9f18b99f8d866c071166e94f43912b35eedc6062267d4cdb5842bde7c54426c751b1bb76103ec11eb8daa682772a1f71c50962811dbc694 | ||
DIST autopep8-1.3.5.tar.gz 109415 BLAKE2B e30a9719dcb2ce5463adc967ea76daa1c919c4b26e879ad69416e06bdff873e288b43a86f2cd797e67428c969e60dfb1f63508bbd8eec8f818f2abd4f68409e9 SHA512 3f7b441ede0efe01b3123e9349eeddc1eb62e6198c79e95e7eee532a3c9eca0cedfd4fdb50a872da9be93ad79db68fb13972eb984539f9ca4ebc37b05411cf70 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} ) | ||
PYTHON_REQ_USE="threads(+)" | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide" | ||
HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/" | ||
if [[ ${PV} == *9999* ]]; then | ||
EGIT_REPO_URI="https://github.com/hhatto/${PN}.git" | ||
inherit git-r3 | ||
else | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
fi | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
>=dev-python/pep8-1.5.7[${PYTHON_USEDEP}] | ||
>=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]" | ||
|
||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
${RDEPEND} | ||
>=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] | ||
)" | ||
|
||
python_prepare_all() { | ||
# Prevent UnicodeDecodeError with LANG=C | ||
sed -e "/é/d" -i MANIFEST.in || die | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
esetup.py test | ||
} |