Skip to content

Commit

Permalink
media-plugins/vco-plugins: fix HOMEPAGE, SRC_URI, EAPI=5. bug #437186
Browse files Browse the repository at this point in the history
The HOMEPAGE and SRC_URI for kokkinizita upstream was changed
some time ago. These changes point said variables to the new
location. The previous ebuild was EAPI=4 which is deprecated so
bumped to EAPI=5, revbumped and modified ebuild accordingly.

Bug: https://bugs.gentoo.org/show_bug.cgi?id=437186
  • Loading branch information
gavlee committed Oct 30, 2015
1 parent 02141bb commit 24e3525
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions media-plugins/vco-plugins/vco-plugins-0.3.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit multilib toolchain-funcs

MY_P=${P/vco/VCO}

DESCRIPTION="SAW-VCO ladspa plugin package. Anti-aliased oscillators"
HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""

DEPEND="media-libs/ladspa-sdk"
RDEPEND="${DEPEND}"

S=${WORKDIR}/${MY_P}

src_prepare() {
tc-export CXX
sed -i -e "s/-O3//" \
-e "s/g++/$(tc-getCXX) ${LDFLAGS}/" Makefile || die
}

src_install() {
dodoc AUTHORS README
insinto /usr/$(get_libdir)/ladspa
insopts -m0755
doins *.so
}

0 comments on commit 24e3525

Please sign in to comment.