forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/fam: Bump Debian patchset. Use net-libs/libtirpc (bug #6313…
…86). Package-Manager: Portage-2.3.24, Repoman-2.3.6
- Loading branch information
Jeroen Roovers
committed
Mar 4, 2018
1 parent
08dce14
commit 24f2e8a
Showing
4 changed files
with
148 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST fam-2.7.0.tar.gz 301974 BLAKE2B 9a915e61b2898717cac1b7bbe9b2049aee0701314710906c5c8323aafe0847a9f017d09c4d9345e1fba386ac3c1001ec013325f9841d716e8c91e35bcf1e3962 SHA512 62b6222ee925eb2af1e258097c9bb676191690f38f8504ae16b1883a1019e0ac6dc7116ac2c4c596a956b3b3cfc3ce3ee7b613c319654681afb13e3ad3f284e2 | ||
DIST fam_2.7.0-17.2.diff.gz 28826 BLAKE2B 880f8614304b048a24be03231ec26a02901befd75c8c5d51abf07d5afb42f370f4d3702d0db790f2f651f040372791024d9cbfbea15a1932629fb13a7b6a5ec8 SHA512 295c954fcecb7357a72ecf3c7469bb37c29e8969fc7be3a0e92e40e79911c9578f44c42a0a6f900610c8a9886f1addc62e50f258105aaadb61c718f526608697 | ||
DIST fam_2.7.0-17.diff.gz 28056 BLAKE2B 4db010fdf7a2548f5651e9da876df63d3bd0d1a5f184b26df99f7d4204bbcbadf4c7672d248d9d1af2e7297b0ec17a5ec80e6b57016774877465a957ae3c6ae8 SHA512 76b14e1d17713eb86d52cb804d34012e5369b5f4e8bcbdc73a063d2ad9219e0c4a261cef9e144ee07744a953a2e893bdf2ceeefcf21edc7a2ac5e70a51a8e209 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,70 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit autotools eutils flag-o-matic ltprune multilib-minimal | ||
|
||
FAM_PV="${PV/_p*/}" | ||
DEBIAN_PATCH="${PV#*_p}" | ||
DEBIAN_PATCH="${DEBIAN_PATCH/_p/.}" | ||
DESCRIPTION="FAM, the File Alteration Monitor" | ||
HOMEPAGE="http://oss.sgi.com/projects/fam/" | ||
SRC_URI=" | ||
ftp://oss.sgi.com/projects/fam/download/stable/${PN}-${FAM_PV}.tar.gz | ||
mirror://debian/pool/main/f/${PN}/${PN}_${FAM_PV}-${DEBIAN_PATCH}.diff.gz | ||
" | ||
|
||
LICENSE="GPL-2 LGPL-2.1" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
IUSE="static-libs" | ||
|
||
DEPEND=" | ||
!app-admin/gamin | ||
net-libs/libtirpc | ||
net-nds/rpcbind | ||
" | ||
RDEPEND=" | ||
${DEPEND} | ||
" | ||
DOCS=( AUTHORS ChangeLog INSTALL NEWS TODO README ) | ||
S=${WORKDIR}/${PN}-${FAM_PV} | ||
|
||
src_prepare() { | ||
eapply "${WORKDIR}"/${PN}_${FAM_PV}-${DEBIAN_PATCH}.diff | ||
edos2unix debian/patches/10_debianbug375967.patch | ||
eapply "${FILESDIR}"/${PN}-${FAM_PV}-patch-header.patch | ||
|
||
eapply debian/patches/*patch | ||
|
||
eapply "${FILESDIR}"/${PN}-${FAM_PV}-AM_CONFIG_HEADER.patch | ||
eapply "${FILESDIR}"/${PN}-${FAM_PV}-out-of-tree.patch | ||
eapply "${FILESDIR}"/${PN}-${FAM_PV}-sysmacros.patch #580702 | ||
|
||
eapply_user | ||
|
||
eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
tc-export PKG_CONFIG | ||
append-cppflags $(${PKG_CONFIG} --cflags libtirpc) | ||
append-libs $(${PKG_CONFIG} --libs libtirpc) | ||
ECONF_SOURCE=${S} econf $(use_enable static-libs static) | ||
|
||
# These are thrown away later | ||
if ! multilib_is_native_abi ; then | ||
sed -i -e 's/src conf man//' Makefile || die | ||
fi | ||
} | ||
|
||
multilib_src_install_all() { | ||
prune_libtool_files | ||
einstalldocs | ||
|
||
sed -i "${D}"/etc/fam.conf \ | ||
-e "s:local_only = false:local_only = true:g" \ | ||
|| die "sed fam.conf" | ||
|
||
doinitd "${FILESDIR}/famd" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -7,7 +7,7 @@ | ||
AM_INIT_AUTOMAKE | ||
AM_MAINTAINER_MODE | ||
dnl AC_CONFIG_SRCDIR([acconfig.h]) | ||
-AM_CONFIG_HEADER([config.h]) | ||
+AC_CONFIG_HEADERS([config.h]) | ||
AC_LANG(C++) | ||
|
||
# Variables used by the FAM source. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
--- a/debian/patches/15-partial_send.patch | ||
+++ b/debian/patches/15-partial_send.patch | ||
@@ -1,6 +1,6 @@ | ||
diff -Naur fam-2.7.0/fam-2.7.0/src/NetConnection.c++ fam-2.7.0-mod/fam-2.7.0/src/NetConnection.c++ | ||
---- fam-2.7.0/fam-2.7.0/src/NetConnection.c++ 2003-01-18 09:18:12.000000000 -0500 | ||
-+++ fam-2.7.0-mod/fam-2.7.0/src/NetConnection.c++ 2007-07-30 12:57:19.812380334 -0400 | ||
+--- a/src/NetConnection.c++ 2003-01-18 09:18:12.000000000 -0500 | ||
++++ b/src/NetConnection.c++ 2007-07-30 12:57:19.812380334 -0400 | ||
@@ -213,6 +213,7 @@ | ||
|
||
msgList_t * msg = new msgList_t; | ||
@@ -31,8 +31,8 @@ | ||
{ | ||
/* Since the client library can close it's fd before | ||
diff -Naur fam-2.7.0/fam-2.7.0/src/NetConnection.h fam-2.7.0-mod/fam-2.7.0/src/NetConnection.h | ||
---- fam-2.7.0/fam-2.7.0/src/NetConnection.h 2003-01-18 09:18:12.000000000 -0500 | ||
-+++ fam-2.7.0-mod/fam-2.7.0/src/NetConnection.h 2007-07-30 12:53:46.746803625 -0400 | ||
+--- a/src/NetConnection.h 2003-01-18 09:18:12.000000000 -0500 | ||
++++ b/src/NetConnection.h 2007-07-30 12:53:46.746803625 -0400 | ||
@@ -80,6 +80,7 @@ | ||
typedef struct msgList_s { | ||
char msg[MAXMSGSIZE+5]; // + 4 for 32-bit length, + 1 for overflow | ||
--- a/debian/patches/16-port_number.patch | ||
+++ b/debian/patches/16-port_number.patch | ||
@@ -1,6 +1,6 @@ | ||
diff -Naur fam-2.7.0/fam-2.7.0/man/famd.8 fam-2.7.0-mod/fam-2.7.0/man/famd.8 | ||
---- fam-2.7.0/fam-2.7.0/man/famd.8 2003-01-19 19:58:11.000000000 -0500 | ||
-+++ fam-2.7.0-mod/fam-2.7.0/man/famd.8 2007-07-30 12:23:15.292527117 -0400 | ||
+--- a/man/famd.8 2003-01-19 19:58:11.000000000 -0500 | ||
++++ b/man/famd.8 2007-07-30 12:23:15.292527117 -0400 | ||
@@ -51,6 +51,9 @@ | ||
Register with the portmapper using the specifed RPC program | ||
and version numbers. | ||
@@ -12,8 +12,8 @@ | ||
Poll a remove NFS server every \fIperiod\fR seconds | ||
to obtain file updates if the remove server is not running \fBfamd\fR. | ||
diff -Naur fam-2.7.0/fam-2.7.0/src/Listener.c++ fam-2.7.0-mod/fam-2.7.0/src/Listener.c++ | ||
---- fam-2.7.0/fam-2.7.0/src/Listener.c++ 2003-01-19 19:37:29.000000000 -0500 | ||
-+++ fam-2.7.0-mod/fam-2.7.0/src/Listener.c++ 2007-07-26 16:32:03.863758810 -0400 | ||
+--- a/src/Listener.c++ 2003-01-19 19:37:29.000000000 -0500 | ||
++++ b/src/Listener.c++ 2007-07-26 16:32:03.863758810 -0400 | ||
@@ -60,13 +60,14 @@ | ||
|
||
static void cleanup_negotiation(void *closure); | ||
@@ -57,8 +57,8 @@ | ||
if (listen(sock, 1) < 0) | ||
{ | ||
diff -Naur fam-2.7.0/fam-2.7.0/src/Listener.h fam-2.7.0-mod/fam-2.7.0/src/Listener.h | ||
---- fam-2.7.0/fam-2.7.0/src/Listener.h 2003-01-18 09:18:12.000000000 -0500 | ||
-+++ fam-2.7.0-mod/fam-2.7.0/src/Listener.h 2007-07-26 16:32:50.682255289 -0400 | ||
+--- a/src/Listener.h 2003-01-18 09:18:12.000000000 -0500 | ||
++++ b/src/Listener.h 2007-07-26 16:32:50.682255289 -0400 | ||
@@ -51,7 +51,9 @@ | ||
|
||
Listener(bool started_by_inetd, | ||
@@ -79,8 +79,8 @@ | ||
// Private Instance Methods | ||
|
||
diff -Naur fam-2.7.0/fam-2.7.0/src/main.c++ fam-2.7.0-mod/fam-2.7.0/src/main.c++ | ||
---- fam-2.7.0/fam-2.7.0/src/main.c++ 2003-01-19 01:15:51.000000000 -0500 | ||
-+++ fam-2.7.0-mod/fam-2.7.0/src/main.c++ 2007-05-08 16:42:35.618954322 -0400 | ||
+--- a/src/main.c++ 2003-01-19 01:15:51.000000000 -0500 | ||
++++ b/src/main.c++ 2007-05-08 16:42:35.618954322 -0400 | ||
@@ -89,6 +89,7 @@ | ||
fprintf(stderr, "\t-d\t\tdebug\n"); | ||
fprintf(stderr, "\t-v\t\tverbose\n"); |