Skip to content

Commit

Permalink
kde-apps/konsole: backport patch from upstream solving --new-tab regr…
Browse files Browse the repository at this point in the history
…ession

Gentoo-bug: 615850
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
kensington committed Apr 25, 2017
1 parent 9ce4714 commit 253b683
Show file tree
Hide file tree
Showing 2 changed files with 90 additions and 0 deletions.
31 changes: 31 additions & 0 deletions kde-apps/konsole/files/konsole-16.12.3-newtabs.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
From e3de3ca72552c81bc8d7dbe5cf1568eedd33c31e Mon Sep 17 00:00:00 2001
From: "Martin T. H. Sandsmark" <[email protected]>
Date: Wed, 25 Jan 2017 22:25:48 +0100
Subject: [PATCH] Fix opening of new tabs with multiple processes

Make sure we re-use the process if the user wants a new tab.

BUG: 373440
REVIEW: 129886
---
src/main.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/main.cpp b/src/main.cpp
index f4bb5af..33a2bdb 100644
--- a/src/main.cpp
+++ b/src/main.cpp
@@ -117,8 +117,8 @@ extern "C" int Q_DECL_EXPORT kdemain(int argc, char* argv[])
parser->process(*app);
about.processCommandLine(parser.data());

- // Enable user to force multiple instances
- if (!Konsole::KonsoleSettings::useSingleInstance()) {
+ // Enable user to force multiple instances, unless a new tab is requested
+ if (!Konsole::KonsoleSettings::useSingleInstance() && !parser->isSet(QStringLiteral("new-tab"))) {
startupOption = KDBusService::Multiple;
}

--
2.10.2

59 changes: 59 additions & 0 deletions kde-apps/konsole/konsole-16.12.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

KDE_HANDBOOK="optional"
KDE_TEST="true"
VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="KDE's terminal emulator"
HOMEPAGE="https://www.kde.org/applications/system/konsole https://konsole.kde.org"

KEYWORDS="~amd64 ~x86"
IUSE="X"

DEPEND="
$(add_frameworks_dep kbookmarks)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdbusaddons)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kinit)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep knotifyconfig)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kpty)
$(add_frameworks_dep kservice)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtprintsupport)
$(add_qt_dep qtscript)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
X? ( x11-libs/libX11 )
"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${P}-newtabs.patch" )

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package X X11)
)

kde5_src_configure
}

0 comments on commit 253b683

Please sign in to comment.