Skip to content

Commit

Permalink
sys-libs/e2fsprogs-libs: Bump to version 1.43.9
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Feb 9, 2018
1 parent 0be0036 commit 254b6e7
Show file tree
Hide file tree
Showing 2 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/e2fsprogs-libs/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST e2fsprogs-libs-1.43.3.tar.gz 599387 BLAKE2B decdb20114ad7b00754ecfe5658de64
DIST e2fsprogs-libs-1.43.6.tar.gz 595409 BLAKE2B a5edf65b637b7f3fab16174a695baa232b8aeab6e8d28140a3a68ed63eee309949ca85a28f33d15199068fffe9174ef76b28f403ec09118296a458611592a36e SHA512 80a643ba349aac79c88548e9692066f777c5f9e82e309b348606a8078de456171535e6e5df91f73ca3db9d03bb539b1a19883cf74615357bdf77f3bd20cc0b11
DIST e2fsprogs-libs-1.43.7.tar.gz 595431 BLAKE2B 12677792ff602586fa41f15c16a19b9d4135be8a4d8e4f26d40a8ee5b09254bec34f3ec6186b386fe0ef5690f26b2be54a46931eb5c76bf0693ce5877927fdc4 SHA512 b57c069d2e95588823fd69169378dd9d8a04ca77daa1a5dda8398cd198ace6184a3cb08507ae2b195de399caa4d197306043749f4a3010bccd942ba00d44162b
DIST e2fsprogs-libs-1.43.8.tar.gz 596246 BLAKE2B 6847f177ccfdb06b49f58951b258647ec11b1237e3d33e44c2f7c6b93569445010914921d9447c842eba141c31a9982c72558dc6eb62fb2b24d1574a3204b1a8 SHA512 3127351310542326102dbbe84dade4043ff7f3046fb84e3364036a0975103a0aa146ba02400400e73affa658b93a69d0cb14855c2ab8f6da5b88d9ea0f17c9e8
DIST e2fsprogs-libs-1.43.9.tar.gz 595452 BLAKE2B 2f4c8b07abe343f304f3217984ec03a38dca2d69765d7e9edef184c5b478fb0aa860fb0338a41e9d2d47c55780b0e44450efbe2528110403a77696af9e0c9d7c SHA512 c4b78000ace629a7e6f12d7c63f5ff36885bc7ba69a22654f95fd384bb347f0f28ba544644b40cdcbf14ec211e724901fbe44cc2b730f2dafba77632b3e2d0b1
70 changes: 70 additions & 0 deletions sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.43.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

case ${PV} in
*_pre*) UP_PV="${PV%_pre*}-WIP-${PV#*_pre}" ;;
*) UP_PV=${PV} ;;
esac

inherit toolchain-funcs eutils multilib-minimal

DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
HOMEPAGE="http://e2fsprogs.sourceforge.net/"
SRC_URI="mirror://sourceforge/e2fsprogs/${PN}-${UP_PV}.tar.gz
mirror://kernel/linux/kernel/people/tytso/e2fsprogs/v${UP_PV}/${PN}-${UP_PV}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~m68k-mint ~x86-solaris"
IUSE="nls static-libs"

RDEPEND="!sys-libs/com_err
!sys-libs/ss
!<sys-fs/e2fsprogs-1.41.8"
DEPEND="nls? ( sys-devel/gettext )
virtual/pkgconfig"

S="${WORKDIR}/${P%_pre*}"

PATCHES=(
"${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
)

src_prepare() {
printf 'all:\n%%:;@:\n' > doc/Makefile.in # don't bother with docs #305613
default
}

multilib_src_configure() {
local myconf=(
$(tc-is-static-only || echo --enable-elf-shlibs)
$(tc-has-tls || echo --disable-tls)
$(use_enable nls)
)
# we use blkid/uuid from util-linux now
if use kernel_linux ; then
export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
myconf+=( --disable-lib{blkid,uuid} )
fi
ac_cv_path_LDCONFIG=: \
ECONF_SOURCE="${S}" \
CC="$(tc-getCC)" \
BUILD_CC="$(tc-getBUILD_CC)" \
BUILD_LD="$(tc-getBUILD_LD)" \
econf "${myconf[@]}"
}

multilib_src_compile() {
emake V=1
}

multilib_src_install() {
emake V=1 STRIP=: DESTDIR="${D}" install || die
gen_usr_ldscript -a com_err ss $(usex kernel_linux '' 'uuid blkid')
# configure doesn't have an option to disable static libs :/
if ! use static-libs ; then
find "${ED}" -name '*.a' -delete || die
fi
}

0 comments on commit 254b6e7

Please sign in to comment.