forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/lxc: put terribly old ebuild back in place
Package-Manager: Portage-2.3.18, Repoman-2.3.6 RepoMan-Options: --force
- Loading branch information
Showing
3 changed files
with
224 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST lxc-1.0.11.tar.gz 850645 BLAKE2B 1a8eff91d970d3160d5ca7338f4e4d68c722a277a804396e7c30b34dbf4aeccc0609982940bb660992880078167cdf3382a55af404b3e52ebe8cd8af104b1efc SHA512 5537e61a286cfce3c763b81eec625538c796ea1e8f5e94c5a28fc8964762c8c0efa7983a188d521bf3420a42569d7124e6587950bc90b79583fa42cc8e2f8f74 | ||
DIST lxc-1.0.8.tar.gz 575127 BLAKE2B 246ac7a2b4306c52a741b2f763bcc81d9999fb27942ef93d6a786ed2ea010c646f5a2388407d26425387b8a819cacae927c8512995bf19b11d610e1887ea6470 SHA512 f552a4f48bb47d26c6b9ddaf8221a439c0848e3f54ec41b77d54717c21bddd56193941046cc96c699790e8265e762a926469c25ee687adcf7795f2906b1c260a | ||
DIST lxc-2.0.7.tar.gz 792557 BLAKE2B e5f1e6d8961938200e116527fab8ce341cf285826afdccac88f4bae65ffd649a406dac7555024557f38c4b415a59cd3b5fb255f1dbf015ce01d4975bed3b1c80 SHA512 eb48dc800ce43d2f4d46e0cecc4d0a714b3e22c6a4975776b54d17d1d20d5a1411e6b605215282f1f77286ddf22b61c80b86b83752191fc18023894ef7a1c44d | ||
DIST lxc-2.0.8.tar.gz 1308705 BLAKE2B 044e82e182f4ca325da237b888ff16b0469eb11ecdab2ed55f5e9372e84d816ec30edee28ef1473aaa7211a9d9aee0d26f45f169320551e45098da9de7a74104 SHA512 ed9fd47e92007f433695cffea659180866a5ac2778712f4eb13b6629bb18292589f5b674b734853ca196ba1f6d38bdbf3cc8a2bb28e25d3540b06b945fcf9096 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
Index: lxc-lxc-1.0.8/config/bash/Makefile.am | ||
=================================================================== | ||
--- lxc-lxc-1.0.8.orig/config/bash/Makefile.am | ||
+++ lxc-lxc-1.0.8/config/bash/Makefile.am | ||
@@ -2,12 +2,12 @@ EXTRA_DIST = lxc | ||
|
||
if ENABLE_BASH | ||
install-bash: | ||
- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/ | ||
- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/ | ||
+ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/ | ||
+ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/ | ||
|
||
uninstall-bash: | ||
- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc | ||
- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || : | ||
+ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc | ||
+ rmdir $(DESTDIR)$(datarootdir)/bash-completion// || : | ||
|
||
install-data-local: install-bash | ||
uninstall-local: uninstall-bash | ||
Index: lxc-lxc-1.0.8/config/bash/lxc.in | ||
=================================================================== | ||
--- lxc-lxc-1.0.8.orig/config/bash/lxc.in | ||
+++ lxc-lxc-1.0.8/config/bash/lxc.in | ||
@@ -1,4 +1,3 @@ | ||
-have lxc-start && { | ||
_lxc_names() { | ||
COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) ) | ||
} | ||
@@ -100,4 +99,3 @@ have lxc-start && { | ||
|
||
complete -o default -F _lxc_generic_o lxc-clone | ||
complete -o default -F _lxc_generic_o lxc-start-ephemeral | ||
-} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,188 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="5" | ||
|
||
MY_P="${P/_/-}" | ||
PYTHON_COMPAT=( python3_4 ) | ||
DISTUTILS_OPTIONAL=1 | ||
|
||
inherit autotools bash-completion-r1 distutils-r1 eutils linux-info versionator flag-o-matic systemd | ||
|
||
DESCRIPTION="LinuX Containers userspace utilities" | ||
HOMEPAGE="https://linuxcontainers.org/" | ||
SRC_URI="https://github.com/lxc/lxc/archive/${MY_P}.tar.gz" | ||
|
||
KEYWORDS="amd64 ~arm ~arm64 ppc64 x86" | ||
|
||
LICENSE="LGPL-3" | ||
SLOT="0" | ||
IUSE="doc examples lua python seccomp" | ||
|
||
RDEPEND="net-libs/gnutls | ||
sys-libs/libcap | ||
lua? ( >=dev-lang/lua-5.1:= ) | ||
python? ( ${PYTHON_DEPS} ) | ||
seccomp? ( sys-libs/libseccomp )" | ||
|
||
DEPEND="${RDEPEND} | ||
doc? ( app-text/docbook-sgml-utils ) | ||
>=sys-kernel/linux-headers-3.2" | ||
|
||
RDEPEND="${RDEPEND} | ||
sys-apps/util-linux | ||
app-misc/pax-utils | ||
virtual/awk" | ||
|
||
CONFIG_CHECK="~CGROUPS ~CGROUP_DEVICE | ||
~CPUSETS ~CGROUP_CPUACCT | ||
~RESOURCE_COUNTERS | ||
~CGROUP_SCHED | ||
~NAMESPACES | ||
~IPC_NS ~USER_NS ~PID_NS | ||
~DEVPTS_MULTIPLE_INSTANCES | ||
~CGROUP_FREEZER | ||
~UTS_NS ~NET_NS | ||
~VETH ~MACVLAN | ||
~POSIX_MQUEUE | ||
~!NETPRIO_CGROUP | ||
~!GRKERNSEC_CHROOT_MOUNT | ||
~!GRKERNSEC_CHROOT_DOUBLE | ||
~!GRKERNSEC_CHROOT_PIVOT | ||
~!GRKERNSEC_CHROOT_CHMOD | ||
~!GRKERNSEC_CHROOT_CAPS | ||
~!GRKERNSEC_PROC | ||
" | ||
|
||
ERROR_DEVPTS_MULTIPLE_INSTANCES="CONFIG_DEVPTS_MULTIPLE_INSTANCES: needed for pts inside container" | ||
|
||
ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers" | ||
|
||
ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info" | ||
ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network" | ||
|
||
ERROR_VETH="CONFIG_VETH: needed for internal (host-to-container) networking" | ||
ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking" | ||
|
||
ERROR_POSIX_MQUEUE="CONFIG_POSIX_MQUEUE: needed for lxc-execute command" | ||
|
||
ERROR_NETPRIO_CGROUP="CONFIG_NETPRIO_CGROUP: as of kernel 3.3 and lxc 0.8.0_rc1 this causes LXCs to fail booting." | ||
|
||
ERROR_GRKERNSEC_CHROOT_MOUNT=":CONFIG_GRKERNSEC_CHROOT_MOUNT some GRSEC features make LXC unusable see postinst notes" | ||
ERROR_GRKERNSEC_CHROOT_DOUBLE=":CONFIG_GRKERNSEC_CHROOT_DOUBLE some GRSEC features make LXC unusable see postinst notes" | ||
ERROR_GRKERNSEC_CHROOT_PIVOT=":CONFIG_GRKERNSEC_CHROOT_PIVOT some GRSEC features make LXC unusable see postinst notes" | ||
ERROR_GRKERNSEC_CHROOT_CHMOD=":CONFIG_GRKERNSEC_CHROOT_CHMOD some GRSEC features make LXC unusable see postinst notes" | ||
ERROR_GRKERNSEC_CHROOT_CAPS=":CONFIG_GRKERNSEC_CHROOT_CAPS some GRSEC features make LXC unusable see postinst notes" | ||
ERROR_GRKERNSEC_PROC=":CONFIG_GRKERNSEC_PROC: this GRSEC feature is incompatible with unprivileged containers" | ||
|
||
DOCS=(AUTHORS CONTRIBUTING MAINTAINERS NEWS README doc/FAQ.txt) | ||
|
||
S="${WORKDIR}/${PN}-${MY_P}" | ||
|
||
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )" | ||
|
||
src_prepare() { | ||
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die | ||
if [[ -n ${BACKPORTS} ]]; then | ||
epatch "${WORKDIR}"/patches/* | ||
fi | ||
|
||
epatch "${FILESDIR}"/${PN}-1.0.8-bash-completion.patch | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
append-flags -fno-strict-aliasing | ||
|
||
econf \ | ||
--localstatedir=/var \ | ||
--bindir=/usr/sbin \ | ||
--docdir=/usr/share/doc/${PF} \ | ||
--with-config-path=/etc/lxc \ | ||
--with-rootfs-path=/usr/lib/lxc/rootfs \ | ||
--with-distro=gentoo \ | ||
$(use_enable doc) \ | ||
--disable-apparmor \ | ||
$(use_enable examples) \ | ||
$(use_enable lua) \ | ||
$(use_enable seccomp) \ | ||
--disable-python | ||
} | ||
|
||
python_compile() { | ||
distutils-r1_python_compile build_ext -I ../ -L ../${PN} | ||
} | ||
|
||
src_compile() { | ||
default | ||
|
||
if use python; then | ||
pushd "${S}/src/python-${PN}" > /dev/null | ||
distutils-r1_src_compile | ||
popd > /dev/null | ||
fi | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
mv "${ED}"/usr/share/bash-completion/completions/${PN} "${ED}"/$(get_bashcompdir)/${PN}-start || die | ||
bashcomp_alias ${PN}-start \ | ||
${PN}-{attach,cgroup,clone,console,create,destroy,device,execute,freeze,info,monitor,snapshot,start-ephemeral,stop,unfreeze,wait} | ||
|
||
if use python; then | ||
pushd "${S}/src/python-lxc" > /dev/null | ||
# Unset DOCS. This has been handled by the default target | ||
unset DOCS | ||
distutils-r1_src_install | ||
popd > /dev/null | ||
fi | ||
|
||
keepdir /etc/lxc /usr/lib/lxc/rootfs /var/log/lxc | ||
|
||
find "${D}" -name '*.la' -delete | ||
|
||
# Gentoo-specific additions! | ||
# Use initd.3 per #517144 | ||
newinitd "${FILESDIR}/${PN}.initd.3" ${PN} | ||
|
||
# lxc-devsetup script | ||
exeinto /usr/libexec/${PN} | ||
doexe config/init/systemd/${PN}-devsetup | ||
# Use that script with the systemd service (Similar to upstream | ||
# Makefile.am | ||
cp "${FILESDIR}"/${PN}_at.service ${PN}_at.service || die | ||
sed -i \ | ||
"/Restart=always/a ExecStartPre=/usr/libexec/${PN}/${PN}-devsetup" \ | ||
${PN}_at.service \ | ||
|| die "Failed to add ${PN}-devsetup to the systemd service file" | ||
systemd_newunit ${PN}_at.service "[email protected]" | ||
} | ||
|
||
pkg_postinst() { | ||
elog "There is an init script provided with the package now; no documentation" | ||
elog "is currently available though, so please check out /etc/init.d/lxc ." | ||
elog "You _should_ only need to symlink it to /etc/init.d/lxc.configname" | ||
elog "to start the container defined into /etc/lxc/configname.conf ." | ||
elog "For further information about LXC development see" | ||
elog "http://blog.flameeyes.eu/tag/lxc" # remove once proper doc is available | ||
elog "" | ||
ewarn "With version 0.7.4, the mountpoint syntax came back to the one used by 0.7.2" | ||
ewarn "and previous versions. This means you'll have to use syntax like the following" | ||
ewarn "" | ||
ewarn " lxc.rootfs = /container" | ||
ewarn " lxc.mount.entry = /usr/portage /container/usr/portage none bind 0 0" | ||
ewarn "" | ||
ewarn "To use the Fedora, Debian and (various) Ubuntu auto-configuration scripts, you" | ||
ewarn "will need sys-apps/yum or dev-util/debootstrap." | ||
ewarn "" | ||
ewarn "Some GrSecurity settings in relation to chroot security will cause LXC not to" | ||
ewarn "work, while others will actually make it much more secure. Please refer to" | ||
ewarn "Diego Elio Pettenò's weblog at http://blog.flameeyes.eu/tag/lxc for further" | ||
ewarn "details." | ||
} |