Skip to content

Commit

Permalink
games-misc/xcowsay: add 1.6
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Feb 3, 2022
1 parent 4e91032 commit 25cb948
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-misc/xcowsay/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xcowsay-1.5.1.tar.gz 101281 BLAKE2B 568f6ad7225cd859c37d79bf3ddf66c184f47d8feb6dedbafbd29ca4e05d97d883c6d6e4f4d60cebe107f1527e1ff01e17ec61430a3e55e2f504c2c00e402488 SHA512 55c165b5b2c01b11463af0eeb13fd646ea50138e2938ddfc25d44f1a704b7473d047bc7c95165f449a600de51ee005904f007843e33a8ef02c725b827eaec616
DIST xcowsay-1.6.tar.gz 292845 BLAKE2B 88597063616928edfc74830171b287b676163faca0b3545dc4495cb0faee810ca7867f36223bba726074866de7fb3458621670265250c846ce94c035a0ad0828 SHA512 53016e1b2790b8bc213702f1b99a0ca0cacc57ef1c2cf821814ecb4aff68df05c98b279a1f39718f4fcee771e1397b27ad43123314b1f04dd442ddc0520a9f98
56 changes: 56 additions & 0 deletions games-misc/xcowsay/xcowsay-1.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools

DESCRIPTION="Displays a cute cow and message on your desktop"
HOMEPAGE="
https://github.com/nickg/xcowsay
https://www.doof.me.uk/xcowsay/
"
SRC_URI="https://github.com/nickg/${PN}/releases/download/v${PV}/${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dbus fortune nls"
RESTRICT="test"

RDEPEND="
dev-libs/glib:2
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/pango
dbus? ( dev-libs/dbus-glib )
fortune? ( games-misc/fortune-mod )
"

DEPEND="${RDEPEND}"

BDEPEND="
sys-devel/gettext
virtual/pkgconfig
"

src_prepare() {
default

if ! use fortune; then
sed -e 's/xcowfortune//g' -i src/Makefile.am || die
fi

eautoreconf
}

src_configure() {
local myeconfargs=(
--disable-rpath
$(use_enable dbus)
$(use_enable nls)
)

econf ${myeconfargs[@]}
}

0 comments on commit 25cb948

Please sign in to comment.