Skip to content

Commit

Permalink
sys-apps/dog: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
monsieurp committed Jun 26, 2017
1 parent ab5cddd commit 25d8d33
Show file tree
Hide file tree
Showing 5 changed files with 51 additions and 8 deletions.
43 changes: 43 additions & 0 deletions sys-apps/dog/dog-1.7-r6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs

DESCRIPTION="Dog is better than cat"
# the best HOMEPAGE we have.
HOMEPAGE="https://packages.gentoo.org/package/sys-apps/dog"
SRC_URI="mirror://gentoo/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc64-solaris"

PATCHES=(
"${FILESDIR}"/${P}-check-ctime.diff
"${FILESDIR}"/${PV}-manpage-touchup.patch
"${FILESDIR}"/${P}-64bit-goodness.patch
"${FILESDIR}"/${P}-strfry.patch
)

src_prepare() {
default

if [[ "${CHOST}" == *-solaris* ]]; then
sed -i '/gcc.*-o dog/s/$/ -lsocket -lnsl/' \
Makefile || die "sed Makefile failed"
fi

sed -i \
-e 's,^CFLAGS,#CFLAGS,' \
-e "s,gcc,$(tc-getCC)," \
-e 's:-o dog:$(LDFLAGS) -o dog:g' \
Makefile || die "sed Makefile failed"
}

src_install() {
dobin "${PN}"
doman "${PN}.1"
einstalldocs
}
4 changes: 2 additions & 2 deletions sys-apps/dog/files/1.7-manpage-touchup.patch
Original file line number Diff line number Diff line change
Expand Up @@ -4,8 +4,8 @@ so let's fix it.

http://bugs.gentoo.org/show_bug.cgi?id=69660

--- dog.1
+++ dog.1
--- a/dog.1
+++ b/dog.1
@@ -8,3 +8,3 @@
.B dog
-[\-AbBeEnstTuv] [\-w cols] [\-l lines]
Expand Down
4 changes: 2 additions & 2 deletions sys-apps/dog/files/dog-1.7-64bit-goodness.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
diff -ur dog-1.7/dog.c dog-1.7-64bit/dog.c
--- dog-1.7/dog.c 2000-06-21 18:04:43.000000000 +0200
+++ dog-1.7-64bit/dog.c 2005-05-23 10:40:58.613766328 +0200
--- a/dog.c 2000-06-21 18:04:43.000000000 +0200
+++ b/dog.c 2005-05-23 10:40:58.613766328 +0200
@@ -38,22 +38,13 @@
#include <limits.h>
#include <netdb.h>
Expand Down
4 changes: 2 additions & 2 deletions sys-apps/dog/files/dog-1.7-check-ctime.diff
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
diff --exclude='*~' --exclude='.*' -I '# $Id$
--- dog-1.7.orig/dog.c 2005-05-13 08:01:37.000000000 -0400
+++ dog-1.7/dog.c 2005-05-13 08:30:38.000000000 -0400
--- a/dog.c 2005-05-13 08:01:37.000000000 -0400
+++ b/dog.c 2005-05-13 08:30:38.000000000 -0400
@@ -36,6 +36,7 @@
#include <string.h>
#include "getopt.h"
Expand Down
4 changes: 2 additions & 2 deletions sys-apps/dog/files/dog-1.7-strfry.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
See Gentoo bug 251675. Upstream appears to be dead.

--- dog.c.orig 2009-04-09 23:29:16.307661147 -0500
+++ dog.c 2009-04-09 23:30:11.353664890 -0500
--- a/dog.c 2009-04-09 23:29:16.307661147 -0500
+++ b/dog.c 2009-04-09 23:30:11.353664890 -0500
@@ -552,7 +552,7 @@

// strfry()
Expand Down

0 comments on commit 25d8d33

Please sign in to comment.