forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libmediainfo: version bump to 20.03
Signed-off-by: Tim Harder <[email protected]>
- Loading branch information
Showing
2 changed files
with
84 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST libmediainfo_19.09.tar.xz 1764640 BLAKE2B aa1a93cbbdf17e2b1eb20efed4909c5d86e897796e1e184f1bb5eed50e1eb154f426b420551e25cb220f66059618b6f719c47333b816258eea6e3c30304892b2 SHA512 7f3afbb1c2df6e2dec44485a4eda8609d6b95c1b8e41354cef6b94549f77a506e237c7d43f5472aadf1c0ef2bd88dc24ba0eb493a763ba51871bb287233ae779 | ||
DIST libmediainfo_20.03.tar.xz 1799940 BLAKE2B a0c50ab27e29b010e33334c207872aefc110396401065d3bebdc6cf34aba325453b87e9f1f1ecfe9882bf5f63aaa26f3bbfe3d791cb0c16fa75ca4bb7ff081f0 SHA512 97dd847edf0e290f7ea0153c71a442cc54944bf295f195486f37fa81230cf4463ae2ecc154e73cf75b876b33c038020a9ff082013d57381ab5516a4a2db5ef87 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,83 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit autotools eutils flag-o-matic | ||
|
||
MY_PN="MediaInfo" | ||
DESCRIPTION="MediaInfo libraries" | ||
HOMEPAGE="https://mediaarea.net/mediainfo/ https://github.com/MediaArea/MediaInfoLib" | ||
SRC_URI="https://mediaarea.net/download/source/${PN}/${PV}/${P/-/_}.tar.xz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="curl doc mms static-libs" | ||
|
||
RDEPEND="sys-libs/zlib | ||
dev-libs/tinyxml2:= | ||
>=media-libs/libzen-0.4.37[static-libs=] | ||
curl? ( net-misc/curl ) | ||
mms? ( >=media-libs/libmms-0.6.1[static-libs=] )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen )" | ||
|
||
# tests try to fetch data from online sources | ||
RESTRICT="test" | ||
|
||
S=${WORKDIR}/${MY_PN}Lib/Project/GNU/Library | ||
|
||
src_prepare() { | ||
eapply -p4 "${FILESDIR}"/${PN}-0.7.63-pkgconfig.patch | ||
eapply_user | ||
|
||
sed -i 's:-O2::' configure.ac || die | ||
append-cppflags -DMEDIAINFO_LIBMMS_DESCRIBE_SUPPORT=0 | ||
|
||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--enable-shared \ | ||
--with-libtinyxml2 \ | ||
$(use_with curl libcurl) \ | ||
$(use_with mms libmms) \ | ||
$(use_enable static-libs static) \ | ||
$(use_enable static-libs staticlibs) | ||
} | ||
|
||
src_compile() { | ||
default | ||
|
||
if use doc; then | ||
cd "${WORKDIR}"/${MY_PN}Lib/Source/Doc | ||
doxygen Doxyfile || die | ||
fi | ||
} | ||
|
||
src_install() { | ||
if use doc; then | ||
local HTML_DOCS=( "${WORKDIR}"/${MY_PN}Lib/Doc/*.html ) | ||
fi | ||
|
||
default | ||
|
||
edos2unix ${PN}.pc #414545 | ||
insinto /usr/$(get_libdir)/pkgconfig | ||
doins ${PN}.pc | ||
|
||
for x in ./ Archive Audio Duplicate Export Image Multiple Reader Tag Text Video; do | ||
insinto /usr/include/${MY_PN}/${x} | ||
doins "${WORKDIR}"/${MY_PN}Lib/Source/${MY_PN}/${x}/*.h | ||
done | ||
|
||
insinto /usr/include/${MY_PN}DLL | ||
doins "${WORKDIR}"/${MY_PN}Lib/Source/${MY_PN}DLL/*.h | ||
|
||
dodoc "${WORKDIR}"/${MY_PN}Lib/*.txt | ||
|
||
find "${ED}" -name '*.la' -delete || die | ||
} |