Skip to content

Commit

Permalink
app-portage/metagen: Python 3.11 + DistutilsNonPEP517Build + MissingR…
Browse files Browse the repository at this point in the history
…emoteId

Signed-off-by: Sebastian Pipping <[email protected]>
  • Loading branch information
hartwork committed Nov 28, 2022
1 parent 9cb96d7 commit 25e747a
Show file tree
Hide file tree
Showing 3 changed files with 41 additions and 1 deletion.
3 changes: 3 additions & 0 deletions app-portage/metagen/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,7 @@
<email>[email protected]</email>
<name>Sebastian Pipping</name>
</maintainer>
<upstream>
<remote-id type="pypi">metagen</remote-id>
</upstream>
</pkgmetadata>
36 changes: 36 additions & 0 deletions app-portage/metagen/metagen-0.7.3-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="8"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1

DESCRIPTION="metadata.xml generator for ebuilds"
HOMEPAGE="https://cgit.gentoo.org/proj/metagen.git"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"

IUSE=""
DEPEND="dev-python/lxml[${PYTHON_USEDEP}]
sys-apps/portage[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"

python_install_all() {
distutils-r1_python_install_all
doman docs/metagen.1

# Bug 814545 and 832069
if [[ ${PF} != ${P} ]]; then # to be robust across bumps
mv "${ED}"/usr/share/doc/${P}/* "${ED}"/usr/share/doc/${PF}/ || die
rmdir "${ED}"/usr/share/doc/${P}/ || die
fi
}

python_test() {
"${PYTHON}" -c "from metagen import metagenerator; metagenerator.do_tests()" || die
}
3 changes: 2 additions & 1 deletion app-portage/metagen/metagen-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2

EAPI="8"
PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1 git-r3

Expand Down

0 comments on commit 25e747a

Please sign in to comment.