Skip to content

Commit

Permalink
app-portage/repoman: Version bump, fix 9999 deps
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
dol-sen committed Dec 12, 2016
1 parent 4bbbb33 commit 25eaf16
Show file tree
Hide file tree
Showing 3 changed files with 75 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-portage/repoman/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST repoman-2.3.0-bug-586864.patch 1074 SHA256 4ad35afd9237be63c1c2c21348501499c252c4bf828a04f08ca0a129e091001d SHA512 b48112a623a4844e5783f229ee0208f729b99ab46128d19735a76633efee17deb81342b5dc8fa67f4f4f5a851509c04c8d2f2ba2cbd992a9d26e61da4ed5f7e8 WHIRLPOOL f1cb4d9a11d8958fae726642bd0d12a0bb8d6564077c09b961fa2f0448c0503132683b4199e37f7cbd5bfd01adb1eede50496ed9b2ad32572284eacd3b2cd2dc
DIST repoman-2.3.0.tar.bz2 75285 SHA256 e67d1a2dbb89f44e64a49259e64affcf138ade8ad0f397b93c9cbdecd517b726 SHA512 960c63caed12f7c89d374ecceb39677b62d588bf75cc8da1857641c60310061188f4c2fd7177c93a4e8f20cf00a423426f2a70666320f263158531a618a7ff9c WHIRLPOOL bff6d55a4abc5032cd3d04d8e56ec3bb7902c6877836ca4b129f5a57480c01eb6a6225b75fd0cc0b6a2a2991728896ddef3b7ee2a225a901c0523d88d99cecf6
DIST repoman-2.3.0_rc1.tar.bz2 74621 SHA256 e1de34b710cd43787a91ab49e0b0a6ca32d942ee130ec74523b00f3c5f4ccefa SHA512 7594053472512ab66a269acd1e5f3a9191a519df061ed65b612af0ee30f830ff71ab6b602416aa968476fec1f534ecf313317a28df6120b74c7379197b769983 WHIRLPOOL 9e00736856879f222eaa2f8330109e92b8c7d262ed5a1ef0cf0c3c36f84dfdedfea2de202043aba7585f42353e1ebaf04b16329c812d7e71f957cf697899abd0
DIST repoman-2.3.1.tar.bz2 76678 SHA256 93a39ff20eac6166ec29497ae2476cc168ea35d8822aaed33a3010fe9c2abf91 SHA512 6655027acaa6b98b7fdf927b6744e87b6ea09fe6d61653874aeb5603943aa9fc68df9435335dfc8f51d25949354660eaccdd1c8b659dbc87aea7a2f8bf3dfd16 WHIRLPOOL 29ddd58a8585a3926853beb66afe5d1a41a16667c9155b7dbc08a63ec02ea8873b304ac7267e3525341cd49c15dcc0dc01e0d0802c61a438fb75b113b7aafd66
72 changes: 72 additions & 0 deletions app-portage/repoman/repoman-2.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} )
PYTHON_REQ_USE='bzip2(+)'

inherit distutils-r1

DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
IUSE=""

RDEPEND="
>=sys-apps/portage-2.3.0_rc[${PYTHON_USEDEP}]
>=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"

python_prepare_all() {
distutils-r1_python_prepare_all

if [[ -n "${EPREFIX}" ]] ; then
einfo "Prefixing shebangs ..."

local file
while read -r -d $'\0' file; do
local shebang=$(head -n1 "${file}")

if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "${file}" || \
die "sed failed"
fi
done < <(find . -type f -print0)
fi
}

python_test() {
esetup.py test
}

python_install() {
# Install sbin scripts to bindir for python-exec linking
# they will be relocated in pkg_preinst()
distutils-r1_python_install \
--system-prefix="${EPREFIX}/usr" \
--bindir="$(python_get_scriptdir)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
--sbindir="$(python_get_scriptdir)" \
--sysconfdir="${EPREFIX}/etc" \
"${@}"
}

pkg_postinst() {
einfo ""
einfo "This release of repoman is from the new portage/repoman split"
einfo "release code base."
einfo "This new repoman code base is still being developed. So its API's"
einfo "are not to be considered stable and are subject to change."
einfo "The code released has been tested and considered ready for use."
einfo "This however does not guarantee it to be completely bug free."
einfo "Please report any bugs you may encounter."
einfo ""
}
4 changes: 2 additions & 2 deletions app-portage/repoman/repoman-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -28,8 +28,8 @@ DEPEND="

RDEPEND="
dev-lang/python-exec:2
=sys-apps/portage-9999
>=dev-python/lxml-3.6.0
=sys-apps/portage-9999[${PYTHON_USEDEP}]
>=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
"

SRC_ARCHIVES="https://dev.gentoo.org/~dolsen/releases/repoman"
Expand Down

0 comments on commit 25eaf16

Please sign in to comment.