Skip to content

Commit

Permalink
sci-libs/hipFFT: add 5.7.1
Browse files Browse the repository at this point in the history
Signed-off-by: Benda Xu <[email protected]>
  • Loading branch information
heroxbd committed Nov 19, 2023
1 parent dfec413 commit 26095f9
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-libs/hipFFT/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST hipFFT-rocm-5.1.3.tar.gz 89397 BLAKE2B 3c29d5d660e9f3db8afd8c9e524296c29f50faf06a5d6a58ec628b5cc5ddb47ac2b99f137c7bc5090a311189b44014ea2f6f1f7547d22506f5ba18f837fbeb68 SHA512 8d7a90630cd8bfeade9cb026e45b6b6c1ab9c96dba424559a7ced8c881cd45c1cb06d3f7e82c8e6558e4ccb8bb41b6278842057a0cf0957b0644b1139f2c9706
DIST hipFFT-rocm-5.7.1.tar.gz 102616 BLAKE2B ee8d6dcb7924c8989987b02533126c4e4419d8dc83067a816f2253efe4537e094f1665d95699d4bf27f30cd13f3fc5df7d3b0062c267ecbdcbb3aad961fab6f6 SHA512 4bfd812fa1e949574b4170833755a435f47e893f0615b65d8d273af6e8f89ea4d28632a208de20321e834c8bc237b11816e2af0363b60adca9af736b9bc87465
45 changes: 45 additions & 0 deletions sci-libs/hipFFT/hipFFT-5.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ROCM_VERSION=${PV}

inherit cmake rocm

DESCRIPTION="CU / ROCM agnostic hip FFT implementation"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipFFT"
SRC_URI="https://github.com/ROCmSoftwarePlatform/hipFFT/archive/refs/tags/rocm-${PV}.tar.gz -> hipFFT-rocm-${PV}.tar.gz"
REQUIRED_USE="${ROCM_REQUIRED_USE}"

LICENSE="MIT"
KEYWORDS="~amd64"
SLOT="0/$(ver_cut 1-2)"

RESTRICT="test"

RDEPEND="dev-util/hip
sci-libs/rocFFT:${SLOT}[${ROCM_USEDEP}]"
DEPEND="${RDEPEND}"
BDEPEND=""

S="${WORKDIR}/hipFFT-rocm-${PV}"

PATCHES=(
"${FILESDIR}/${PN}-5.0.2-remove-git-dependency.patch"
"${FILESDIR}/${PN}-4.3.0-add-complex-header.patch"
)

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_INCLUDEDIR="include/hipfft"
-DCMAKE_MODULE_PATH="${EPREFIX}"/usr/$(get_libdir)/cmake/hip
-DHIP_ROOT_DIR="${EPREFIX}/usr"
-DROCM_SYMLINK_LIBS=OFF
-DBUILD_CLIENTS_TESTS=OFF
-DBUILD_CLIENTS_RIDER=OFF
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
)

CXX=hipcc cmake_src_configure
}

0 comments on commit 26095f9

Please sign in to comment.