Skip to content

Commit

Permalink
app-emulation/free42: 2.5.20 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Bernard Cafarelli <[email protected]>
  • Loading branch information
voyageur committed Oct 7, 2020
1 parent 3a1bea1 commit 260c483
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/free42/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST free42-nologo-2.5.14.tgz 7410951 BLAKE2B 5d8087269da86a2c8c00378a3bc51d2f85
DIST free42-nologo-2.5.16.tgz 7412652 BLAKE2B bdea95adca140eecbb192706a5e611c1ad5d248b47aa609ac2733eb018ea74e7661a1797acf9458aa07b6015df7376b3ef329685cff984d364c2f5e26f7d213b SHA512 5adfe5ce09e3aecae7f05d3880234eb903eb48b36ee10e88be87a8941752323f97067b97cb85699fc03591fc355024eb6cd621f64c31e6e5c6dd4d5027f1ba34
DIST free42-nologo-2.5.17.tgz 7412893 BLAKE2B ce8a06d290d4fcc12fd9b98c9bb80e12b3dc0a8d53b87cba874bce5798812d667c9e61ac4d990ace9828b10bf223adb1e32274ca11837ec50b4b0559fe8d92ac SHA512 64efdb93a33780095360eb987ca5fa192336b285dcf785a268db59fa4aa8cf2c8ce91b8242c9b4d5efa9c4556f5d688894f60056117e1c0774147894e59d32c9
DIST free42-nologo-2.5.18.tgz 7413195 BLAKE2B c3d7d92c2f9b527fb6932f46644cb306217ab103bde1ecfd52a2659a1a71eaef199abeda8b24977e338757bfd57c824c31bc3bf9aa396e3372629b04737e6232 SHA512 3543d0a0cc4dff9c96c1121f221dded40f2574fffbd4747ef179b0d5cf75a003f49bc548df554fb46504af787d9d2fdb434c23a420f4b3592c838f4d00ac7140
DIST free42-nologo-2.5.20.tgz 7414358 BLAKE2B f1e0963e6a808121efc4d9bd82863d8c7898f65504d4c59f6a6beadc0c4e5c1335ce4c65d25550a3f4d5c080e1933ad30f6325661af4a513f69941c48adda1a5 SHA512 04a01f29ed5a3c9374de98ead6c54191dbde6b0e3d9923b5c89f18f868630b50235711820e751e4a1e3efc0600b1a7a105e8800f660d67124458a8f2826c840f
50 changes: 50 additions & 0 deletions app-emulation/free42/free42-2.5.20.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

MY_PV="${PN}-nologo-${PV}"

DESCRIPTION="An HP-42S Calculator Simulator"
HOMEPAGE="https://thomasokken.com/free42/"
SRC_URI="https://thomasokken.com/free42/upstream/${MY_PV}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+alsa"

DEPEND="dev-libs/atk
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
alsa? ( media-libs/alsa-lib )"

RDEPEND="${DEPEND}"

DOCS=( CREDITS HISTORY README )
S="${WORKDIR}/${MY_PV}"

PATCHES=(
"${FILESDIR}/${PN}-2.5.16-fix-makefile.patch"
"${FILESDIR}/${PN}-2.5.3-fix-build-intel-lib.patch"
)

src_prepare() {
default
}

src_compile() {
local myconf
use alsa && myconf="AUDIO_ALSA=yes"
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
emake -C gtk clean
emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
}

src_install() {
default
dobin gtk/free42bin gtk/free42dec
}

0 comments on commit 260c483

Please sign in to comment.