Skip to content

Commit

Permalink
dev-python/debugpy: add 1.6.3
Browse files Browse the repository at this point in the history
Signed-off-by: Arthur Zamarin <[email protected]>
  • Loading branch information
arthurzam committed Aug 16, 2022
1 parent 794e4b4 commit 260d6e1
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/debugpy/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST debugpy-1.6.2.gh.tar.gz 6684477 BLAKE2B ab1bdf394d3447ba347db149e5c4c36820df6df24c5d0984fe862419a490cea21b240322d76644bc9ebadbdf9a6d6c8709ae28452828d42b45d65edd2d2e58cb SHA512 64ecd9f8290588358abcff538f2c68025f14efc38ac5b406f32cd40a580aab90e0b2f145de90ca81943872c70969d6294ac51b3151bc4e03f18370ddfbb9ac6c
DIST debugpy-1.6.3.gh.tar.gz 6697583 BLAKE2B 38138be3294615e78995575c8f8ad1f990733be90cfaf76197c714e84f179086501417cc2d64627d3a8ecd0fa451e14e3229bd14d02353bc7512e288e8d4f092 SHA512 c055351351f6705b7bbab93ec07abba09027f1f2a52d90a242f51b4eb6fec19821fbb251b8c8e80587d1333faa4c6d7cab5dead938e9739c5c45013af8ee46a7
43 changes: 43 additions & 0 deletions dev-python/debugpy/debugpy-1.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1

DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
SRC_URI="
https://github.com/microsoft/${PN}/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"

# This is completely broken
RESTRICT="test"

RDEPEND="dev-python/pydevd[${PYTHON_USEDEP}]"
BDEPEND="test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"

PATCHES=(
"${FILESDIR}/${PN}-1.6.1-unbundle-pydevd.patch"
)

distutils_enable_tests pytest

python_prepare_all() {
# Drop unnecessary and unrecognized option
# __main__.py: error: unrecognized arguments: -n8
# Do not timeout
sed -e '/addopts/d' -e '/timeout/d' -i pytest.ini || die

# Unbundle dev-python/pydevd
rm -r src/debugpy/_vendored tests/tests/test_vendoring.py || die

distutils-r1_python_prepare_all
}

0 comments on commit 260d6e1

Please sign in to comment.