forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-office/auto-multiple-choice: add 1.5.2, WIP, unkeyworded
Signed-off-by: Andreas K. Hüttel <[email protected]>
- Loading branch information
Showing
3 changed files
with
147 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST auto-multiple-choice_1.3.0_sources.tar.gz 4328255 BLAKE2B 7c6337cfa0a12d8dcd9fa640e636c300234ba7e7a34e95a523c5f9836f934da336f6ce792932fffb97b28ae02c577166a3d4d3ea4fd6959786a5c60510b454a2 SHA512 fcfacd071072f5773556c706b6fa0aea4ff3f3752f3a1f40c9e6de7ec870e939adc57e6bd4c90cac80241cc798e02a71c9fc80d9ccf25ad3a10752f937d06da5 | ||
DIST auto-multiple-choice_1.5.2_sources.tar.gz 7729206 BLAKE2B cc7aec00626028e4cd5a0b774d65bb652e12577040baa70823831f4744fa2bdd018fe751e0b9cf16daeacecf39607554dee4bbf8daf2f18fb958232d95672a5b SHA512 b70932112a30d6af10d4c0c3c3f7b9e89b86111305c0279042da82e030d2de8caad1012eadeb6d0d487305d0ee5c91d056979184665dcd9b44cc9078d6703c87 |
94 changes: 94 additions & 0 deletions
94
app-office/auto-multiple-choice/auto-multiple-choice-1.5.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,94 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit toolchain-funcs perl-functions latex-package | ||
|
||
DESCRIPTION="Create and manage multiple choice questionnaries, including automated marking" | ||
HOMEPAGE="http://www.auto-multiple-choice.net/" | ||
SRC_URI="http://download.auto-multiple-choice.net/${PN}_${PV}_sources.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
#KEYWORDS="~amd64 ~x86" # work in progress- dilfridge | ||
IUSE="" | ||
|
||
LANGS="ar es fr ja" | ||
# we deliberately always install de and en, since this way we dont get a problem | ||
# with globs and empty directories... | ||
# | ||
for lala in ${LANGS}; do | ||
IUSE="${IUSE} l10n_${lala}" | ||
done | ||
|
||
COMMON_DEPEND=" | ||
app-text/texlive[cjk,extra,graphics,png,pstricks,science,truetype,xml,X,luatex,xetex,humanities,publishers,l10n_zh] | ||
app-text/poppler:= | ||
dev-perl/XML-LibXML | ||
media-libs/netpbm | ||
media-libs/opencv | ||
l10n_fr? ( app-text/texlive[l10n_fr] ) | ||
l10n_ja? ( app-text/texlive[l10n_ja] ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
app-text/dblatex | ||
app-text/docbook-xml-simple-dtd:* | ||
app-text/docbook-xsl-stylesheets | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
app-text/pdftk | ||
dev-lang/perl:= | ||
dev-perl/Glib-Object-Introspection | ||
dev-perl/Gtk3 | ||
media-gfx/imagemagick | ||
dev-perl/XML-Writer | ||
dev-perl/Archive-Zip | ||
dev-perl/DBI | ||
dev-perl/Pango | ||
dev-perl/Text-CSV | ||
dev-perl/DBD-SQLite | ||
dev-perl/Net-CUPS | ||
dev-perl/Email-Address | ||
dev-perl/Email-MIME | ||
dev-perl/Email-Sender | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-1.5.2-conf.patch" | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
local la | ||
for la in ${LANGS} ; do | ||
if ! use l10n_${la} ; then | ||
# remove languages that we dont want to install. no error on nonexisting files. | ||
rm -vf "I18N/lang/${la}.po" | ||
rm -vf "doc/auto-multiple-choice.${la}.in.xml" "doc/doc-xhtml-site.${la}.xsl.in" | ||
rm -rvf "doc/html/auto-multiple-choice.${la}" "doc/modeles/${la}" | ||
sed -e "s: doc/doc-xhtml-site\\.${la}\\.xsl: :g" -i Makefile || die | ||
fi | ||
done | ||
} | ||
|
||
src_compile() { | ||
perl_set_version | ||
export VENDOR_LIB PVR | ||
|
||
export MAKEOPTS="-j1" | ||
# when doing a parallel build, the package is acting decidedly odd | ||
# e.g., the build seems to succeed while actually stuff fails | ||
# and subsequent error messages do not have any relation to the real problem | ||
# So let's keep this also for easier debugging | ||
|
||
emake \ | ||
GCC_NETPBM="-I/usr/include/netpbm/ -lnetpbm" \ | ||
GCC="$(tc-getCC)" \ | ||
GCC_PP="$(tc-getCXX)" | ||
} | ||
|
||
src_install() { | ||
default | ||
} |
52 changes: 52 additions & 0 deletions
52
app-office/auto-multiple-choice/files/auto-multiple-choice-1.5.2-conf.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
diff -ruN auto-multiple-choice-1.5.2.orig/doc/Makefile auto-multiple-choice-1.5.2/doc/Makefile | ||
--- auto-multiple-choice-1.5.2.orig/doc/Makefile 2021-02-07 23:12:35.000000000 +0100 | ||
+++ auto-multiple-choice-1.5.2/doc/Makefile 2023-06-23 00:05:07.918465419 +0200 | ||
@@ -67,7 +67,7 @@ | ||
%.pdf: export SOURCE_DATE_EPOCH=$(PACKAGE_V_EPOCH) | ||
%.pdf: export SOURCE_DATE_EPOCH_TEX_PRIMITIVES=1 | ||
%.pdf: export FORCE_SOURCE_DATE=1 | ||
-%.pdf: export TEXINPUTS=./img_pdf/: | ||
+%.pdf: export TEXINPUTS=/usr/share/dblatex/latex/style:/usr/share/dblatex/latex/misc:/usr/share/dblatex/latex/graphics:./img_pdf/: | ||
|
||
%.pdf: %.tex $(BLOCK_IMAGES:.svg=.pdf) | ||
set -e ; $(XELATEX) $<; $(XELATEX) $< | ||
diff -ruN auto-multiple-choice-1.5.2.orig/Makefile.conf auto-multiple-choice-1.5.2/Makefile.conf | ||
--- auto-multiple-choice-1.5.2.orig/Makefile.conf 2021-01-29 15:52:23.000000000 +0100 | ||
+++ auto-multiple-choice-1.5.2/Makefile.conf 2023-06-23 00:03:59.662678013 +0200 | ||
@@ -33,13 +33,13 @@ | ||
# directory for executable | ||
BINDIR=/usr/bin | ||
# directory for perl modules | ||
-PERLDIR=/usr/share/perl5 | ||
+PERLDIR=$(VENDOR_LIB) | ||
# directory for some AMC executables, not to be used by end-user | ||
MODSDIR=/usr/lib/AMC | ||
# directory for LaTeX style file | ||
-TEXDIR=/usr/share/texmf/tex/latex/AMC | ||
+TEXDIR=/usr/share/texmf-site/tex/latex/AMC | ||
# directory for LaTeX doc | ||
-TEXDOCDIR=/usr/share/doc/texmf/AMC/ | ||
+TEXDOCDIR=/usr/share/texmf-site/doc/AMC/ | ||
# directory for man (1) files | ||
MAN1DIR=/usr/share/man/man1 | ||
# directory for desktop file | ||
@@ -60,7 +60,7 @@ | ||
# directory for AMC packaged models | ||
MODELSDIR=/usr/share/auto-multiple-choice/models | ||
# directory for documentation (will use html/auto-multiple-choice.* subdirs for HTML docs) | ||
-DOCDIR=/usr/share/doc/auto-multiple-choice | ||
+DOCDIR=/usr/share/doc/$(PVR) | ||
|
||
# directory for Shared MIME-info Database | ||
SHARED_MIMEINFO_DIR=/usr/share/mime/packages | ||
@@ -95,10 +95,3 @@ | ||
|
||
GZIP_REPRODUCIBLE_ARGS=-n | ||
|
||
-# INSTALL USER AND GROUP | ||
- | ||
-ifneq ($(SYSTEM_TYPE),rpm) | ||
-INSTALL_USER=root | ||
-INSTALL_GROUP=root | ||
-endif | ||
- |