forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-misc/gramps: version bump to 4.2.4
Dependency on sci-geosciences/osm-gps-map temporarily removed because we haven't got the right version in Portage yet. Seems to work with python3_5 as well but needs more testing, will officially add support for that version later. Suggested-By: Kevin Simmons <[email protected]> Package-Manager: portage-2.3.1
- Loading branch information
Marek Szuba
committed
Sep 23, 2016
1 parent
5e708f8
commit 2621df4
Showing
4 changed files
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gramps-3.4.5.tar.gz 10444188 SHA256 940b665a2e0dadf7ee310bdd1a1033c20816c856df8a7d6c4e0850a60471dbc7 SHA512 c9b517f58712d9f585dbddcb394d3605a5f823950a8c3c5a4ffd20d1a8523d6b75f9b6193271adabe76edc073dd6b4c20811de62582a2930b84d88922b4e52b3 WHIRLPOOL 4e30108881900883a4cb3c3ee4c9ef78e04d0850c3dbdaf97569f44cdfb2e56463f3f156f041b4dec6650c722f12cc0909689edc9591c97c5b02b1705860c228 | ||
DIST gramps-3.4.9.tar.gz 10190446 SHA256 402a8616efeda730d10941690edb6dfb2719c3f7383e376a404577412676a8f3 SHA512 f15481b3791a98568a0a7f734ef5eb9a1149cf76c5e83f1270eee41bcf3518713391cb271a54177e6e6bbaf78da098d7a7a2a807266c971c1331dbb9d29d5fbb WHIRLPOOL 834777cb20ee7a3ef7a2397eef5a0e70caab02666cf127ba01f6310ac68463ea67733883cd3ca63676b9541dc104da818986d7b249950ae6a30415f5fa1bddee | ||
DIST gramps-4.2.4.tar.gz 18683901 SHA256 25190692f2f0d06e05f0761fef45173dd8d6693762572a62845b544a2c622efa SHA512 640b7b8affc29eee000232a3828f71c6e6e4ee568a4fce2ae8f9eaeabc87682e2dd9e2f1db1e8093e368d86583e80ce3c5261cf223f9cc6e210e7d6272781499 WHIRLPOOL ae118840749364b2904e5ed35f318019c54551305cf98d6e118bf9c539d1507dbce74b46fe66430e53c1115d09d3c73296a91f354ad0bb734e6d182a3ae148d0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/setup.py 2016-09-04 14:44:02.000000000 +0000 | ||
+++ b/setup.py 2016-09-22 12:21:52.496968618 +0000 | ||
@@ -278,7 +278,7 @@ | ||
if packaging: | ||
path = resource_path | ||
else: | ||
- path = os.path.abspath(os.path.join(self.install_data, 'share')) | ||
+ path = '/usr/share' | ||
fp.write(path) | ||
|
||
_install.run(self) |
15 changes: 15 additions & 0 deletions
15
app-misc/gramps/files/gramps-4.2.4-versioned_doc_dir.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
--- a/setup.py 2016-09-04 14:44:02.000000000 +0000 | ||
+++ b/setup.py 2016-09-22 13:08:33.188167127 +0000 | ||
@@ -436,9 +436,9 @@ | ||
CSS_FILES = glob.glob(os.path.join('data', 'css', '*.css')) | ||
SWANKY_PURSE = glob.glob(os.path.join('data', 'css', 'swanky-purse', '*.css')) | ||
SWANKY_IMG = glob.glob(os.path.join('data', 'css', 'swanky-purse', 'images', '*.png')) | ||
-data_files_core.append(('share/doc/gramps', DOC_FILES)) | ||
-data_files_core.append(('share/doc/gramps/example/gedcom', GEDCOM_FILES)) | ||
-data_files_core.append(('share/doc/gramps/example/gramps', GRAMPS_FILES)) | ||
+data_files_core.append(('share/doc/gramps-' + VERSION, DOC_FILES)) | ||
+data_files_core.append(('share/doc/gramps-' + VERSION + '/example/gedcom', GEDCOM_FILES)) | ||
+data_files_core.append(('share/doc/gramps-' + VERSION + '/example/gramps', GRAMPS_FILES)) | ||
data_files_core.append(('share/gramps/images/webstuff', IMAGE_WEB)) | ||
data_files_core.append(('share/gramps/css', CSS_FILES)) | ||
data_files_core.append(('share/gramps/css/swanky-purse', SWANKY_PURSE)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python3_4 ) | ||
|
||
DISTUTILS_SINGLE_IMPL=1 | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Genealogical Research and Analysis Management Programming System" | ||
HOMEPAGE="http://www.gramps.org/" | ||
SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="+reports +exif spell" | ||
|
||
RDEPEND=" | ||
dev-python/bsddb3[${PYTHON_USEDEP}] | ||
>=dev-python/pygobject-3.12:3[${PYTHON_USEDEP}] | ||
dev-python/pyicu[${PYTHON_USEDEP}] | ||
gnome-base/librsvg:2 | ||
x11-libs/cairo | ||
>x11-libs/gtk+-3.14.8:3 | ||
x11-libs/pango[introspection] | ||
x11-misc/xdg-utils | ||
reports? ( media-gfx/graphviz ) | ||
exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] ) | ||
spell? ( | ||
app-text/gtkspell[introspection] | ||
dev-python/gtkspell-python | ||
) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${P}-resourcepath.patch" | ||
"${FILESDIR}/${P}-versioned_doc_dir.patch" | ||
) |