Skip to content

Commit

Permalink
app-misc/spacenavd: 0.8
Browse files Browse the repository at this point in the history
Signed-off-by: Sebastian Pipping <[email protected]>
Package-Manager: Portage-3.0.0, Repoman-2.3.23
  • Loading branch information
hartwork committed Dec 1, 2020
1 parent eeb1c34 commit 26495d7
Show file tree
Hide file tree
Showing 3 changed files with 117 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/spacenavd/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST spacenavd-0.7.1.tar.gz 56703 BLAKE2B 99a918090cf8875e5b5cbb48ceffc383b415d9bbe297e49630c8e48ab78bd547244005b5a91e1bb7abc01382ae332758dfc01297bc8f6fb9a05247330cde8127 SHA512 6bfd76f9187ce77c09cb6ebb73bce45391e675cda51437b647510afef574aa6e3f947f467e03a464e245a5e44f699db1d197a58a06a64a2199686b1ab596517f
DIST spacenavd-0.8.tar.gz 47515 BLAKE2B 5ab3432220ae44222b72b3fe18df096322031e0e2643798f494a87287e89607370cd15da919eececc714aacee1b75708a365feac5a182c901d63bdf4fa9f52c1 SHA512 8bb0dd2a95c602d23c84750e55ee649e7999bce43607cd09559f36a782780ceb15769bc0ed8e35b56f7c4b0724574830c2c06d4d8853b6f997ed8bba04441a05
29 changes: 29 additions & 0 deletions app-misc/spacenavd/files/spacenavd-0.8-version.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
From 22056e975ebc0ff9e02c8ba2ffc61f65f272a567 Mon Sep 17 00:00:00 2001
From: Sebastian Pipping <[email protected]>
Date: Tue, 1 Dec 2020 15:49:19 +0100
Subject: [PATCH] Fix version to be 0.8

---
configure | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/configure b/configure
index 98040a1..e39be6b 100755
--- a/configure
+++ b/configure
@@ -40,11 +40,7 @@ DBG=yes
X11=yes
HOTPLUG=yes
XINPUT=yes
-VER=`git describe --tags 2>/dev/null`
-
-if [ -z "$VER" ]; then
- VER=`git rev-parse --short HEAD`
-fi
+VER=0.8

echo "configuring spacenavd - $VER"

--
2.27.0

87 changes: 87 additions & 0 deletions app-misc/spacenavd/spacenavd-0.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic linux-info systemd toolchain-funcs udev

MY_PN='spacenav'
DESCRIPTION="The spacenavd daemon provides free alternative to the 3dxserv daemon"
HOMEPAGE="http://spacenav.sourceforge.net/"
SRC_URI="https://github.com/FreeSpacenav/spacenavd/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="X"

RDEPEND="X? (
x11-apps/xdpyinfo
x11-base/xorg-proto
x11-libs/libX11
x11-libs/libXi
)"
DEPEND="${RDEPEND}"

PATCHES=(
# https://github.com/FreeSpacenav/spacenavd/issues/29
"${FILESDIR}"/${P}-version.patch
)

pkg_setup() {
CONFIG_CHECK="~INPUT_EVDEV"
ERROR_CFG="Your kernel needs INPUT_EVDEV for the spacenavd to work properly"
check_extra_config
}

src_configure() {
append-cflags -fcommon # bug 708648
econf \
--disable-debug \
--enable-hotplug \
--disable-opt \
$(use_enable X x11)
}

src_compile() {
emake CC="$(tc-getCC)"
}

src_install() {
# Config file
insinto /etc
newins "${S}/doc/example-spnavrc" spnavrc.sample

# Init script
newinitd "${FILESDIR}/spnavd" spacenavd
systemd_dounit "${FILESDIR}/spacenavd.service"

# Install udev rule but leave activiation to the user
# since Xorg may be configured to grab the device already
udev_newrules "${FILESDIR}"/99-space-navigator.rules-r2 99-space-navigator.rules.ignored

# Daemon
dobin "${S}/spacenavd"
use X && dobin "${S}/spnavd_ctl"
}

pkg_postinst() {
elog "To start the Spacenav daemon system-wide by default"
elog "you should add it to the default runlevel :"
elog "\`rc-update add spacenavd default\` (for openRC)"
elog "\`systemctl enable spacenavd\` (for systemd)"
elog
if use X; then
elog "To start generating Spacenav X events by default"
elog "you should add this command in your user startup"
elog "scripts such as .gnomerc or .xinitrc :"
elog "\`spnavd_ctl x11 start\`"
elog
fi
elog
elog "If you want to auto-start the daemon when you plug in"
elog "a SpaceNavigator device, activate the related udev rule :"
elog "\`sudo ln -s $(get_udevdir)/rules.d/99-space-navigator.rules.ignored /etc/udev/rules.d\`"
ewarn "You must restart spnavd \`/etc/init.d/spacenavd restart\` to run"
ewarn "the new version of the daemon or \`systemctl restart spacenavd\`"
ewarn "if using systemd."
}

0 comments on commit 26495d7

Please sign in to comment.