Skip to content

Commit

Permalink
net-misc/ytmdl: bump to 2023.7.27
Browse files Browse the repository at this point in the history
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Aug 27, 2023
1 parent a5bdf7b commit 264c13f
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/ytmdl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ytmdl-2023.2.28.tar.gz 52281 BLAKE2B 5a9dfea6022082b976fb165ca45cb4ae13adac9308cb5671b52bd433eed4b2921bad345c3acaa10f125d06162964c55b82c44468e3d12b52c47ea63d2d1bce71 SHA512 891119c0386bd2079108b9b34f41606c2a6da21de5f574a89b95d6cb5a661611e442ffc10f6f4d94d827318568408ff8d5b58eb3eb602e64afa4efa3728b3855
DIST ytmdl-2023.7.27.tar.gz 53737 BLAKE2B 8f01a8cd9b666904fe29871f5f595bae8dd0d29741c5e7c77886d0444a9b23fbf99e1c0efdadb3a62fa0c37425271724327ad655bd2bfb9a53b81a3cf4705289 SHA512 b300590f1aae0378c3672df24b766c6729b034711f83102881f0bd81d7d383825f3187c6f28611c38ad634542b8eb4bbe2c4fcb8a946b7eef9be492a3bfee927
44 changes: 44 additions & 0 deletions net-misc/ytmdl/ytmdl-2023.7.27.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )

inherit bash-completion-r1 distutils-r1 pypi

DESCRIPTION="Simple app to get songs from youtube in mp3 format"
HOMEPAGE="https://ytmdl.deepjyoti30.dev/
https://github.com/deepjyoti30/ytmdl/"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
>=net-misc/yt-dlp-2022.3.8.2[${PYTHON_USEDEP}]
dev-python/PySocks[${PYTHON_USEDEP}]
dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/ffmpeg-python[${PYTHON_USEDEP}]
dev-python/itunespy[${PYTHON_USEDEP}]
dev-python/pyDes[${PYTHON_USEDEP}]
dev-python/python-musicbrainzngs[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/rich[${PYTHON_USEDEP}]
dev-python/simber[${PYTHON_USEDEP}]
dev-python/spotipy[${PYTHON_USEDEP}]
dev-python/unidecode[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]
dev-python/youtube-search-python[${PYTHON_USEDEP}]
dev-python/ytmusicapi[${PYTHON_USEDEP}]
media-libs/mutagen[${PYTHON_USEDEP}]
net-misc/downloader-cli[${PYTHON_USEDEP}]
"

src_install() {
distutils-r1_src_install
newbashcomp ${PN}.bash ${PN}
}

0 comments on commit 264c13f

Please sign in to comment.