forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/google-api-python-client: add 2.52.0
Signed-off-by: Arthur Zamarin <[email protected]>
- Loading branch information
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST google-api-python-client-2.50.0.gh.tar.gz 30751763 BLAKE2B 4fa967932d13fa03640970ba2b6b1756864d88e4953deb5c9cf89a4556bd2cb3f1083f2e141b89a08936a40ddea64e45d65b5d9afe4024edf94a56c5ccb32798 SHA512 8dcdb85f2f37d4c668924abba46f0012ad453dc0775b373dc9fc510020479b1dc8a22cd85980ab97bcd4e7bdff19c78d829b1d758e9105a71c3ac7aa0cb19946 | ||
DIST google-api-python-client-2.51.0.gh.tar.gz 31181726 BLAKE2B 465cbc3beb870a543bb54b69342d1a4e75026fa3c83846a3641e048b922cfa14ccb56593a0e8feadf4bf30568425347b14f5f1dd081d5d74fa1112bb0d57caa3 SHA512 ea9e9424aa36e077f10922dba9d6bf43f376d5e059c5d0fc7a31ef919232eb7778a891104fe3a7328e841381d5cd2cd76cdfb1fb80458c979f83a935f8b1df5a | ||
DIST google-api-python-client-2.52.0.gh.tar.gz 31712232 BLAKE2B 573226a90617aaf2b0272393694759f2796cbaf26629f4d79ecb661424c6304689fafda7c2d60289840445f118dbae4cf0ffbd6444bc0c428ee4bb8879a57c92 SHA512 55fc06c50240b22ed51ecd84e797eebc4c57852da9c45ca8c0face7e961ab0debe06d6ac91fcc6ef81878fc4b851b8bec7a192a4e149f611fe9e4d8b15cccdc4 |
53 changes: 53 additions & 0 deletions
53
dev-python/google-api-python-client/google-api-python-client-2.52.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{8..10} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Google API Client for Python" | ||
HOMEPAGE=" | ||
https://github.com/googleapis/google-api-python-client/ | ||
https://pypi.org/project/google-api-python-client/ | ||
" | ||
SRC_URI=" | ||
https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz | ||
-> ${P}.gh.tar.gz | ||
" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
|
||
RDEPEND=" | ||
>=dev-python/httplib2-0.15[${PYTHON_USEDEP}] | ||
<dev-python/httplib2-1[${PYTHON_USEDEP}] | ||
>=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}] | ||
>=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}] | ||
>=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}] | ||
<dev-python/uritemplate-5[${PYTHON_USEDEP}] | ||
" | ||
BDEPEND=" | ||
test? ( | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/oauth2client[${PYTHON_USEDEP}] | ||
dev-python/pandas[${PYTHON_USEDEP}] | ||
dev-python/parameterized[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
distutils_enable_tests pytest | ||
|
||
python_test() { | ||
local EPYTEST_DESELECT=( | ||
# require Internet access (and credentials) | ||
tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive | ||
tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object | ||
) | ||
|
||
epytest tests | ||
} |