Skip to content

Commit

Permalink
app-cdr/cdemu: Bump to 3.2.0
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Jul 9, 2018
1 parent e89572c commit 270af26
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-cdr/cdemu/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cdemu-client-3.1.0.tar.bz2 43066 BLAKE2B 97413d06b0466e81dce212c9f621fed2a7b83517c8ef3c70ccf182b48093b9c5f805ee40c81bf23bb88089da758876e80f57094c2ec761d42480a401d3b95114 SHA512 62c0650cfd18c1e8edca8c53a343460bf12aae35909251fce24098f16b48a3b30d083d436f494bf23145c06252f943f75413f024c6744696f5ad75cac0a15509
DIST cdemu-client-3.2.0.tar.bz2 43588 BLAKE2B 0f75bed1ce2a715bb7acf227ebd3da8b80cf6418e28b0d352f294121c1f67acb8c6bab5f5dc5c768150ad46830b823d66f1940887c66225d20b41827c1377d31 SHA512 778f2ecac828ba278d0ded875c7bab2415f1c1acb62f4030eaf161376869939c48bc16a6d660326d9aacd2af745ef9dc9158f922a72aa8ccbd47f05ce41b8cd7
53 changes: 53 additions & 0 deletions app-cdr/cdemu/cdemu-3.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python3_{4,5,6} )

inherit bash-completion-r1 cmake-utils python-single-r1 xdg-utils

DESCRIPTION="Command-line tool for controlling cdemu-daemon"
HOMEPAGE="http://cdemu.org"
SRC_URI="mirror://sourceforge/cdemu/cdemu-client-${PV}.tar.bz2"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="+cdemu-daemon"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_USEDEP}]
cdemu-daemon? ( app-cdr/cdemu-daemon:0/7 )"
DEPEND="${RDEPEND}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
>=sys-devel/gettext-0.18
virtual/pkgconfig"

S=${WORKDIR}/cdemu-client-${PV}

DOCS=( AUTHORS README )

src_prepare() {
cmake-utils_src_prepare

python_fix_shebang src/cdemu
}

src_configure() {
local mycmakeargs=(
-DPOST_INSTALL_HOOKS=OFF
-DCMAKE_INSTALL_COMPLETIONSDIR="$(get_bashcompdir)"
)
cmake-utils_src_configure
}

pkg_postinst() {
xdg_desktop_database_update
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit 270af26

Please sign in to comment.