Skip to content

Commit

Permalink
sys-cluster/zookeeper-bin: Bump to 3.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed May 18, 2022
1 parent ada0e0c commit 274ccde
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/zookeeper-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST zookeeper-bin-3.7.1.tar.gz 12649765 BLAKE2B 1a0fd48185fb2a847d961ffb33387f9bf165f6c7f24eb00c82f1cc413278d48652459a89406dc4af01a4453d39e93be12deb07c0791d2337a43f04e14ce33417 SHA512 9103628a50745fa1a289bca666fda4a9c08ec17c55cf13e66887e7ba76e93dbae60a1f1ffd6c10798be3a16069344ecbc00cebb29bf03d9cd7096ccd098ed011
DIST zookeeper-bin-3.8.0.tar.gz 13185104 BLAKE2B 2afcfbac16a027fb2a009e20a852a747a9a93fb846b214c57ebf6730e73b892aa40037e29013cbc45e87532848bf889d24635becbf7dd554965b7da0a89ac8e0 SHA512 d66e3a40451f840406901b2cd940992b001f92049a372ae48d8b420891605871cd1ae5f6cceb3b10665491e7abef36a4078dace158bd1e0938fcd3567b5234ca
68 changes: 68 additions & 0 deletions sys-cluster/zookeeper-bin/zookeeper-bin-3.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit java-utils-2

MY_PN="zookeeper"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="A high-performance coordination service for distributed applications"
HOMEPAGE="https://zookeeper.apache.org/"
SRC_URI="https://downloads.apache.org/${MY_PN}/${MY_P}/apache-${MY_P}-bin.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/apache-${MY_P}-bin"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="mirror binchecks"

BDEPEND="
acct-group/zookeeper
acct-user/zookeeper
"
RDEPEND="
${BDEPEND}
>=virtual/jre-1.8
"

INSTALL_DIR=/opt/"${PN}"
export CONFIG_PROTECT="${CONFIG_PROTECT} ${INSTALL_DIR}/conf"

src_prepare() {
default
rm "${S}"/docs/skin/instruction_arrow.png || die
}

src_install() {
local DATA_DIR=/var/lib/"${MY_P}"

# cleanup sources
rm bin/*.cmd || die

keepdir "${DATA_DIR}"
sed "s:^dataDir=.*:dataDir=${DATA_DIR}:" conf/zoo_sample.cfg > conf/zoo.cfg || die
cp "${FILESDIR}"/log4j.properties conf/ || die

dodir "${INSTALL_DIR}"
cp -a "${S}"/* "${ED}${INSTALL_DIR}" || die

# data dir perms
fowners zookeeper:zookeeper "${DATA_DIR}"

# log dir
keepdir /var/log/zookeeper
fowners zookeeper:zookeeper /var/log/zookeeper

# init script
newinitd "${FILESDIR}"/zookeeper.initd zookeeper
newconfd "${FILESDIR}"/zookeeper.confd zookeeper

# env file
cat > 99"${PN}" <<-EOF
PATH="${INSTALL_DIR}"/bin
CONFIG_PROTECT="${INSTALL_DIR}"/conf
EOF
doenvd 99"${PN}"
}

0 comments on commit 274ccde

Please sign in to comment.