Skip to content

Commit

Permalink
media-sound/audacity: Fixed compilation with USE="-portmixer"
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/624264
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Lars Wendler committed Feb 21, 2018
1 parent 18dbd4f commit 2756b16
Show file tree
Hide file tree
Showing 3 changed files with 91 additions and 2 deletions.
9 changes: 7 additions & 2 deletions media-sound/audacity/audacity-2.2.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2

EAPI=5
inherit eutils gnome2-utils wxwidgets xdg-utils
inherit autotools eutils gnome2-utils wxwidgets xdg-utils

MY_P="${PN}-minsrc-${PV}"
DOC_PV="${PV}"
Expand Down Expand Up @@ -50,11 +50,16 @@ REQUIRED_USE="soundtouch? ( midi )"
S="${WORKDIR}/${MY_P}-rc1"

PATCHES=(
"${FILESDIR}/${PN}-2.2.2-midi.patch"
"${FILESDIR}/${PN}-2.2.1-portmixer.patch" #624264
"${FILESDIR}/${PN}-2.2.2-automake.patch" # or else eautoreconf breaks
"${FILESDIR}/${PN}-2.2.2-midi.patch" #637110
)

src_prepare() {
epatch "${PATCHES[@]}"

# needed because of portmixer patch
eautoreconf
}

src_configure() {
Expand Down
36 changes: 36 additions & 0 deletions media-sound/audacity/files/audacity-2.2.1-portmixer.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
https://bugs.gentoo.org/624264

Patch by Vladimir

--- audacity-minsrc-2.2.1-rc3/configure.ac
+++ audacity-minsrc-2.2.1-rc3/configure.ac
@@ -540,7 +540,7 @@
[compile with PortMixer [default=yes]])],
use_portmixer=$withval,
use_portmixer="yes")
-
+AM_CONDITIONAL([USE_PORTMIXER], [test "$use_portmixer" = yes])

AC_CANONICAL_HOST

--- audacity-minsrc-2.2.1-rc3/lib-src/Makefile.am
+++ audacity-minsrc-2.2.1-rc3/lib-src/Makefile.am
@@ -92,7 +92,6 @@
libsoxr \
lib-widget-extra \
lv2 \
- portmixer \
portsmf \
sbsms \
$(NULL)
@@ -156,8 +155,10 @@
SUBDIRS += portaudio-v19
endif

+if USE_PORTMIXER
# Note: portmixer needs to be linked against (the local or system) portaudio.
SUBDIRS += portmixer
+endif

if USE_LOCAL_PORTSMF
SUBDIRS += portsmf
48 changes: 48 additions & 0 deletions media-sound/audacity/files/audacity-2.2.2-automake.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
Remove subdirs that are non-exisitng in the tarball
or else autoreconf breaks.

--- audacity-minsrc-2.2.2-rc1/lib-src/Makefile.am
+++ audacity-minsrc-2.2.2-rc1/lib-src/Makefile.am
@@ -107,18 +107,6 @@
SUBDIRS = FileDialog
OPTIONAL_SUBDIRS =

-if USE_LOCAL_EXPAT
-OPTIONAL_SUBDIRS += expat
-endif
-
-if USE_LOCAL_LIBID3TAG
-OPTIONAL_SUBDIRS += libid3tag
-endif
-
-if USE_LOCAL_LIBMAD
-OPTIONAL_SUBDIRS += libmad
-endif
-
if USE_LOCAL_LIBNYQUIST
SUBDIRS += libnyquist
endif
@@ -131,23 +119,10 @@
OPTIONAL_SUBDIRS += libsoxr
endif

-if USE_LOCAL_LIBSOUNDTOUCH
-OPTIONAL_SUBDIRS += soundtouch
-endif
-
if USE_LOCAL_LIBTWOLAME
OPTIONAL_SUBDIRS += twolame
endif

-if USE_LOCAL_LIBVORBIS
-OPTIONAL_SUBDIRS += libogg libvorbis
-endif
-
-if USE_LOCAL_LIBFLAC
-# Note: libflac needs to be linked against (the local or system) libogg.
-OPTIONAL_SUBDIRS += libflac
-endif
-
if USE_LOCAL_LV2
SUBDIRS += lv2
endif

0 comments on commit 2756b16

Please sign in to comment.