forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/virtualbox-extpack-oracle: Bump to version 4.3.38
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Jul 14, 2016
1 parent
89181dc
commit 278b1ae
Showing
2 changed files
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
41 changes: 41 additions & 0 deletions
41
app-emulation/virtualbox-extpack-oracle/virtualbox-extpack-oracle-4.3.38.106717.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,41 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit eutils multilib versionator | ||
|
||
MAIN_PV="$(get_version_component_range 1-3)" | ||
if [[ ${PV} = *_beta* ]] || [[ ${PV} = *_rc* ]] ; then | ||
MY_PV="${MAIN_PV}_$(get_version_component_range 5)" | ||
MY_PV="${MY_PV/beta/BETA}" | ||
MY_PV="${MY_PV/rc/RC}" | ||
else | ||
MY_PV="${MAIN_PV}" | ||
fi | ||
VBOX_BUILD_ID="$(get_version_component_range 4)" | ||
MY_PN="Oracle_VM_VirtualBox_Extension_Pack" | ||
MY_P="${MY_PN}-${MY_PV}-${VBOX_BUILD_ID}" | ||
|
||
DESCRIPTION="PUEL extensions for VirtualBox" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}.vbox-extpack -> ${MY_P}.tar.gz" | ||
|
||
LICENSE="PUEL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
RESTRICT="mirror strip" | ||
|
||
RDEPEND="~app-emulation/virtualbox-${MAIN_PV}" | ||
|
||
S="${WORKDIR}" | ||
|
||
QA_PREBUILT="/usr/$(get_libdir)/virtualbox/ExtensionPacks/${MY_PN}/.*" | ||
|
||
src_install() { | ||
insinto /usr/$(get_libdir)/virtualbox/ExtensionPacks/${MY_PN} | ||
doins -r linux.${ARCH} | ||
doins ExtPack* PXE-Intel.rom | ||
} |