forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/virtualbox-modules: Bump to version 4.3.38
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Jul 14, 2016
1 parent
4e1fe76
commit 278d6a6
Showing
2 changed files
with
60 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
59 changes: 59 additions & 0 deletions
59
app-emulation/virtualbox-modules/virtualbox-modules-4.3.38.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,59 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
# XXX: the tarball here is just the kernel modules split out of the binary | ||
# package that comes from virtualbox-bin | ||
|
||
EAPI=5 | ||
|
||
inherit eutils linux-mod user | ||
|
||
MY_P=vbox-kernel-module-src-${PV} | ||
DESCRIPTION="Kernel Modules for Virtualbox" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="pax_kernel" | ||
|
||
RDEPEND="!=app-emulation/virtualbox-9999" | ||
|
||
S=${WORKDIR} | ||
|
||
BUILD_TARGETS="all" | ||
BUILD_TARGET_ARCH="${ARCH}" | ||
MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})" | ||
|
||
pkg_setup() { | ||
linux-mod_pkg_setup | ||
|
||
BUILD_PARAMS="KERN_DIR=${KV_DIR} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1" | ||
enewgroup vboxusers | ||
} | ||
|
||
src_prepare() { | ||
if kernel_is -ge 2 6 33 ; then | ||
# evil patch for new kernels - header moved | ||
grep -lR linux/autoconf.h * | xargs sed -i -e 's:<linux/autoconf.h>:<generated/autoconf.h>:' | ||
fi | ||
|
||
if use pax_kernel && kernel_is -ge 3 0 0 ; then | ||
epatch "${FILESDIR}"/${PN}-4.1.4-pax-const.patch | ||
fi | ||
} | ||
|
||
src_install() { | ||
linux-mod_src_install | ||
insinto /usr/lib/modules-load.d/ | ||
doins "${FILESDIR}"/virtualbox.conf | ||
} | ||
|
||
pkg_postinst() { | ||
linux-mod_pkg_postinst | ||
elog "If you are using sys-apps/openrc, please add \"vboxdrv\", \"vboxnetflt\"" | ||
elog "and \"vboxnetadp\" to:" | ||
elog " /etc/conf.d/modules" | ||
} |