Skip to content

Commit

Permalink
dev-lua/busted: add 2.1.1
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Aug 24, 2022
1 parent 9ebfa4a commit 27ca696
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/busted/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST busted-2.0.0.tar.gz 55002 BLAKE2B 39a3b7bf156911e25f94020f9e56b3f43b9f02b910a9d1c1f288dbdb83e5d53253d5b40d73df655844ed683cff7959d42c330c0d061db918385df07870e16da3 SHA512 3151694b1fba1acc52e3bcfee0231008b14934e89da5885d7e063c6f023479c42040c42a8c0aa6ff1f8303ad6b2a70f0687c8a218830de7231007ef8748457bf
DIST busted-2.1.1.tar.gz 62594 BLAKE2B 3afd49dd70b27243e32f69d5d5a0a0ee13e46fdbe46fe6921e1b854abddaa45dba098f19c5994d5656eca871beacd654cac20abe0662c21f6e7efaff19984753 SHA512 80a362094398b85f2783ca11adfae1f7ead38b9de7d11d2c2f8234f2d8f1289dc853f58c11c375b8edd6ea87807a65cc8bce01ebcf7cdf75701796ee528a75a0
63 changes: 63 additions & 0 deletions dev-lua/busted/busted-2.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LUA_COMPAT=( lua5-{1..4} luajit )

inherit lua

DESCRIPTION="Elegant Lua unit testing"
HOMEPAGE="http://olivinelabs.com/busted/"
SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
RESTRICT="test"

RDEPEND="
dev-lua/lua_cliargs[${LUA_USEDEP}]
dev-lua/luafilesystem[${LUA_USEDEP}]
dev-lua/luasystem[${LUA_USEDEP}]
dev-lua/dkjson[${LUA_USEDEP}]
dev-lua/say[${LUA_USEDEP}]
dev-lua/luassert[${LUA_USEDEP}]
dev-lua/lua-term[${LUA_USEDEP}]
dev-lua/penlight[${LUA_USEDEP}]
dev-lua/mediator_lua[${LUA_USEDEP}]
${LUA_DEPS}
"

DEPEND="${RDEPEND}"

BDEPEND="
virtual/pkgconfig
test? (
dev-lua/busted
${RDEPEND}
)
"

lua_src_test() {
busted --lua=${ELUA} || die
}

src_test() {
lua_foreach_impl lua_src_test
}

lua_src_install() {
insinto $(lua_get_lmod_dir)
doins -r busted
}

src_install() {
dobin bin/busted

lua_foreach_impl lua_src_install

einstalldocs
}

0 comments on commit 27ca696

Please sign in to comment.