Skip to content

Commit

Permalink
sys-fs/aufs3: Bump to latest aufs release
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Nov 2, 2015
1 parent eb5bdf5 commit 27f2b8d
Show file tree
Hide file tree
Showing 2 changed files with 173 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/aufs3/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST aufs3-standalone-3_p20150525.tar.xz 2988108 SHA256 117be76206e67425c4144174
DIST aufs3-standalone-3_p20150608.tar.xz 3015460 SHA256 cdf92d07f45becfeb70ea3314e554ea9c8766a2815c3aa6c8d634b5307c76d5d SHA512 4d29d2d4908cd7a4471bc3efe5c23e57d41765937c700eee8593a5c07d7e84e12e6093ef4338b6bd4e9e6f0e44674557a659fd5fa5257a79b381385d208c2209 WHIRLPOOL ccf68e64eb5bc1893c2e5d50c6fc3eaf4e71fd06949ae16e4343734dca39f7f016ab0a08796d444efe55947a8645193979c0dccce702d8c38e46207bfde4f1ad
DIST aufs3-standalone-3_p20150622.tar.xz 3063280 SHA256 2fa44f9df9d58df7a5251ebd2cec206fa90ca8e110c1f657df18e62adb170517 SHA512 fe7a62249130d68f72b14f21b57e5d6db402f56637afc876068d916e78884d08476c804ac58ef06eeb9e13e0a2e1cb75ac782f83054f1c06cb85c74a3c48ba01 WHIRLPOOL 7f85a5324d51e148c97109357c13fcab76121d25ee006211d2212f9c6d352330be110569848c8ca96421bc4582025c73030329d7e501837e4d18cafd6002f153
DIST aufs3-standalone-3_p20151012.tar.xz 3122148 SHA256 f54f1f19bec26f653939e00b30007a465a1f555356ec3886f2a5970276494d0e SHA512 fcf251f358c0dfb66387744d1a1339b2bbcc979c7cc86d01068d108abd6a765c69ecce56cc182d385006febf5abf093fb2c2af77e4cc149134ac413a26b4118f WHIRLPOOL 06be7483792bceea58b26d733c1eed6f69ddd81cd49617550c3414e1800964690b69c1ee9f12b1d48887d051d6b0488a009a56aec0df7cbcc5625ca27f9043f8
DIST aufs3-standalone-3_p20151102.tar.xz 3139016 SHA256 8d43e3c3c744ddfd250321d7a43ac98c77ff93d2775674f3c7a71183260702fb SHA512 0c0f261dc295d7b33560796f7baef761d802eac4de6b09be9a8f41689f3458149c271025e45d053fb188f56b6b2d6e5a02e159b0fefef090cbb0b44cfad78c4a WHIRLPOOL 1bcd9292362b27c564b5450c84b5f22bb16b2498b34507a78bf30df25c034bce4112ddec688f632f39cd935f1dd15dcf7f18213dc0d13a63aed1e2873da2d89b
172 changes: 172 additions & 0 deletions sys-fs/aufs3/aufs3-3_p20151102.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,172 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo toolchain-funcs

AUFS_VERSION="${PV%%_p*}"
# highest branch version
PATCH_MAX_VER=19
# highest supported version
KERN_MAX_VER=20
# lowest supported version
KERN_MIN_VER=14

DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net/"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs3-standalone-${PV}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"

DEPEND="
dev-util/patchutils
dev-vcs/git"
RDEPEND="
sys-fs/aufs-util
!sys-fs/aufs
!sys-fs/aufs2
!sys-fs/aufs4"

S="${WORKDIR}"/${PN}-standalone

MODULE_NAMES="aufs(misc:${S})"

pkg_setup() {
CONFIG_CHECK+=" !AUFS_FS"
use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
use nfs && CONFIG_CHECK+=" EXPORTFS"
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
use pax_kernel && CONFIG_CHECK+=" PAX" && ERROR_PAX="Please use hardened sources"

# this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
[ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return

get_version
kernel_is lt 3 ${KERN_MIN_VER} 0 && die "the kernel version isn't supported by upstream anymore. Please upgrade."
kernel_is gt 3 ${KERN_MAX_VER} 99 && die "kernel too new"

linux-mod_pkg_setup

if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
PATCH_BRANCH="x-rcN"
elif [[ "${KV_MINOR}" == "14" ]] && [[ "${KV_PATCH}" -ge "21" ]]; then
PATCH_BRANCH="${KV_MINOR}".21+
elif [[ "${KV_MINOR}" == "18" ]] && [[ "${KV_PATCH}" -ge "1" ]]; then
PATCH_BRANCH="${KV_MINOR}".1+
else
PATCH_BRANCH="${KV_MINOR}"
fi

case ${KV_EXTRA} in
"")
elog "It seems you are using vanilla-sources with aufs3"
elog "Please use sys-kernel/aufs-sources with USE=vanilla"
elog "This will save you the nasty reemerge of sys-fs/aufs3 on every kernel upgrade"
;;
"-gentoo")
elog "It seems you are using gentoo-sources with aufs3"
elog "Please use sys-kernel/aufs-sources"
elog "This will save you the nasty reemerge of sys-fs/aufs3 on every kernel upgrade"
;;
esac

pushd "${T}" &> /dev/null
unpack ${A}
cd ${PN}-standalone || die
local module_branch=origin/${PN}.${PATCH_BRANCH}
einfo "Using ${module_branch} as patch source"
git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
if use kernel-patch; then
cd ${KV_DIR}
ewarn "Patching your kernel..."
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch >/dev/null
epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
ewarn "You need to compile your kernel with the applied patch"
ewarn "to be able to load and use the aufs kernel module"
else
eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
eerror "Either enable the kernel-patch useflag to do it with this ebuild"
eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
die "missing kernel patch, please apply it first"
fi
fi
popd &> /dev/null
export PKG_SETUP_HAS_BEEN_RAN=1
}

set_config() {
for option in $*; do
grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
done
}

src_prepare() {
local module_branch=origin/${PN}.${PATCH_BRANCH}

einfo "Using for module creation branch ${module_branch}"
git checkout -q -b local-gentoo ${module_branch} || die

# All config options to off
sed "s:= y:=:g" -i config.mk || die

set_config RDU BRANCH_MAX_127 SBILIST

use debug && set_config DEBUG
use fuse && set_config BR_FUSE POLL
use hfs && set_config BR_HFSPLUS
use inotify && set_config HNOTIFY HFSNOTIFY
use nfs && set_config EXPORT
use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
use ramfs && set_config BR_RAMFS

if use pax_kernel; then
if kernel_is ge 3 11; then
epatch "${FILESDIR}"/pax-3.11.patch
else
epatch "${FILESDIR}"/pax-3.patch
fi
fi

sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
}

src_compile() {
local ARCH=x86

emake \
CC=$(tc-getCC) \
LD=$(tc-getLD) \
LDFLAGS="$(raw-ldflags)" \
ARCH=$(tc-arch-kernel) \
CONFIG_AUFS_FS=m \
KDIR="${KV_OUT_DIR}"
}

src_install() {
linux-mod_src_install

insinto /usr/share/doc/${PF}

use doc && doins -r Documentation

use kernel-patch || doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch

dodoc Documentation/filesystems/aufs/README "${T}"/${PN}-standalone/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch

readme.gentoo_create_doc
}

pkg_postinst() {
readme.gentoo_pkg_postinst
linux-mod_pkg_postinst
}

0 comments on commit 27f2b8d

Please sign in to comment.