Skip to content

Commit

Permalink
dev-python/spyder: version bump 4.1.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Andrew Ammerlaan <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
Nowa-Ammerlaan authored and juippis committed Apr 13, 2020
1 parent d0b7889 commit 27f413d
Show file tree
Hide file tree
Showing 4 changed files with 246 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/spyder/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST spyder-4.1.1.tar.gz 11135335 BLAKE2B fc253ea266b368f372f2f0de30120d58c0e5c6e4cf474ccec0884c5fd3557cbd929eb17c0b9f2ee04745861499e12f54e61566507d844c9cf804bef65b3438d4 SHA512 e778dbac4c3f3462c32c9117ce6f6a8e5f2c8df5317695d76bf7a61995cac7be2e224cb751eda337b32442c9a32a7d53f8779a9288f15ad8d1a7aac9d328237c
DIST spyder-4.1.2.tar.gz 11125567 BLAKE2B 38591301fa9d97836341c9e86134fee1515ce901f42aeb45f606f23f5da7411e45e98e872dda0f0de4504e062eb6aa188d3db15181074220e69624a6b28dd8f6 SHA512 a0aeb1f7eb66f2efd5bb7da6ed7401668ca76e968b9b651882567664925be22ba0748914477876e2c62761442c57fa69c19a9fc6556251ac6db83bcd6088d000
DIST spyder-docs-1022fd8.tar.gz 3539049 BLAKE2B 6d54a990ab681e9ed8a5f1a03e59e86c29eb94af18f29dd6c3b8b782230974cf057d25993b0e0358d0f32aba3fd8740dc94fb173766c094e7954d9f39456e6a5 SHA512 84935fb0665e1981c319484ba97096bf6996cc618d073417d06f3dfb703366429be333203af3ff2fe124cf00cc72e416fbc97734be4e21e9200b104fea167933
DIST spyder-docs-7c0b590.tar.gz 2257637 BLAKE2B 7e9528fde453631227ece3bd8c9163a0b3daadf3a83160b5475f943c49e7a559ff33dfe03531240b99571c535887ecff8459116d566dd7c739c74c4165e00060 SHA512 4d9548cc69db85ae6e93cac64e680460da6f9e76bf8b1265b31fbd4925786d29427de40bf06fd52ba807b0bb8f6c224e35b809c0e015a77013deb383e6d666f8
35 changes: 35 additions & 0 deletions dev-python/spyder/files/spyder-4.1.2-build.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
diff -r -U3 spyder-4.0.0b1.orig/setup.py spyder-4.0.0b1/setup.py
--- spyder-4.0.0b1.orig/setup.py 2018-08-12 04:35:49.000000000 +0700
+++ spyder-4.0.0b1/setup.py 2018-08-14 20:25:32.827148778 +0700
@@ -112,21 +107,6 @@


#==============================================================================
-# Make Linux detect Spyder desktop file
-#==============================================================================
-class MyInstallData(install_data):
- def run(self):
- install_data.run(self)
- if sys.platform.startswith('linux'):
- try:
- subprocess.call(['update-desktop-database'])
- except:
- print("ERROR: unable to update desktop database",
- file=sys.stderr)
-CMDCLASS = {'install_data': MyInstallData}
-
-
-#==============================================================================
# Main scripts
#==============================================================================
# NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
@@ -210,8 +190,7 @@
'Intended Audience :: Science/Research',
'Intended Audience :: Developers',
'Topic :: Scientific/Engineering',
- 'Topic :: Software Development :: Widget Sets'],
- cmdclass=CMDCLASS)
+ 'Topic :: Software Development :: Widget Sets'])


#==============================================================================
55 changes: 55 additions & 0 deletions dev-python/spyder/files/spyder-4.1.2-py3-only.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
diff --git a/setup.py b/setup.py
index 2d5d58b..4adc952 100644
--- a/setup.py
+++ b/setup.py
@@ -31,13 +31,6 @@ import shutil
from distutils.core import setup
from distutils.command.install_data import install_data

-
-#==============================================================================
-# Check for Python 3
-#==============================================================================
-PY3 = sys.version_info[0] == 3
-
-
#==============================================================================
# Minimal Python version sanity check
# Taken from the notebook setup.py -- Modified BSD License
@@ -87,13 +80,8 @@ def get_subpackages(name):
def get_data_files():
"""Return data_files in a platform dependent manner"""
if sys.platform.startswith('linux'):
- if PY3:
- data_files = [('share/applications', ['scripts/spyder3.desktop']),
- ('share/icons', ['img_src/spyder3.png']),
- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
- else:
- data_files = [('share/applications', ['scripts/spyder.desktop']),
- ('share/icons', ['img_src/spyder.png'])]
+ data_files = [('share/applications', ['scripts/spyder.desktop']),
+ ('share/icons', ['img_src/spyder.png'])]
elif os.name == 'nt':
data_files = [('scripts', ['img_src/spyder.ico',
'img_src/spyder_reset.ico'])]
@@ -131,9 +119,7 @@ CMDCLASS = {'install_data': MyInstallData}
# See spyder-ide/spyder#1158.
SCRIPTS = ['%s_win_post_install.py' % NAME]

-if PY3 and sys.platform.startswith('linux'):
- SCRIPTS.append('spyder3')
-else:
+if sys.platform.startswith('linux'):
SCRIPTS.append('spyder')

if os.name == 'nt':
@@ -269,8 +255,7 @@ if 'setuptools' in sys.modules:

setup_args['entry_points'] = {
'gui_scripts': [
- '{} = spyder.app.start:main'.format(
- 'spyder3' if PY3 else 'spyder')
+ '{} = spyder.app.start:main'.format('spyder')
]
}

154 changes: 154 additions & 0 deletions dev-python/spyder/spyder-4.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,154 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7} )

inherit eutils xdg distutils-r1 virtualx

# Commit of documentation to fetch
DOCS_PV="1022fd8"

DESCRIPTION="The Scientific Python Development Environment"
HOMEPAGE="
https://www.spyder-ide.org/
https://github.com/spyder-ide/spyder/
https://pypi.org/project/spyder/"
SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/spyder-ide/${PN}-docs/archive/${DOCS_PV}.tar.gz -> ${PN}-docs-${DOCS_PV}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
>=dev-python/atomicwrites-1.2.0[${PYTHON_USEDEP}]
>=dev-python/chardet-2.0.0[${PYTHON_USEDEP}]
>=dev-python/cloudpickle-0.5.0[${PYTHON_USEDEP}]
>=dev-python/diff-match-patch-20181111[${PYTHON_USEDEP}]
dev-python/intervaltree[${PYTHON_USEDEP}]
>=dev-python/ipython-4.0[${PYTHON_USEDEP}]
~dev-python/jedi-0.15.2[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
>=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
>=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
~dev-python/parso-0.5.2[${PYTHON_USEDEP}]
>=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
>=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
>=dev-python/psutil-5.3[${PYTHON_USEDEP}]
>=dev-python/pygments-2.0[${PYTHON_USEDEP}]
>=dev-python/pylint-0.25[${PYTHON_USEDEP}]
>=dev-python/python-language-server-0.31.9[${PYTHON_USEDEP}]
<dev-python/python-language-server-0.32.0[${PYTHON_USEDEP}]
>=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
>=dev-python/pyzmq-17.0.0[${PYTHON_USEDEP}]
>=dev-python/qdarkstyle-2.8[${PYTHON_USEDEP}]
>=dev-python/qtawesome-0.5.7[${PYTHON_USEDEP}]
>=dev-python/qtconsole-4.6.0[${PYTHON_USEDEP}]
>=dev-python/QtPy-1.5.0[${PYTHON_USEDEP},svg,webengine]
>=dev-python/sphinx-0.6.6[${PYTHON_USEDEP}]
>=dev-python/spyder-kernels-1.9.0[${PYTHON_USEDEP}]
<dev-python/spyder-kernels-1.10.0[${PYTHON_USEDEP}]
dev-python/watchdog[${PYTHON_USEDEP}]"

DEPEND="test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/cython[${PYTHON_USEDEP}]
dev-python/flaky[${PYTHON_USEDEP}]
dev-python/matplotlib[tk,${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-qt[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
dev-python/sympy[${PYTHON_USEDEP}]
dev-python/xarray[${PYTHON_USEDEP}] )"

# Based on the courtesy of Arfrever
# This patch removes a call to update-desktop-database during build
# This fails because access is denied to this command during build
PATCHES=(
"${FILESDIR}/${P}-build.patch"
"${FILESDIR}/${P}-py3-only.patch"
)

distutils_enable_tests pytest
distutils_enable_sphinx docs/doc --no-autodoc

python_prepare_all() {
# move docs into workdir
mv ../spyder-docs-${DOCS_PV}* docs || die

# some tests still depend on QtPy[webkit] which is going to be removed
# spyder itself works fine without webkit
rm spyder/widgets/tests/test_browser.py || die
rm spyder/plugins/onlinehelp/tests/test_pydocgui.py || die
rm spyder/plugins/ipythonconsole/tests/test_ipythonconsole.py || die
rm spyder/plugins/ipythonconsole/tests/test_ipython_config_dialog.py || die
rm spyder/plugins/help/tests/test_widgets.py || die
rm spyder/plugins/help/tests/test_plugin.py || die
# fails to collect
rm spyder/app/tests/test_mainwindow.py || die

# skip online test
rm spyder/widgets/github/tests/test_github_backend.py || die

# AssertionError: assert 'import numpy' == '# import numpy'
sed -i -e 's:test_comment:_&:' \
spyder/plugins/editor/widgets/tests/test_codeeditor.py || die

# AssertionError: assert '' == 'This is some test text!'
sed -i -e 's:test_tab_copies_find_to_replace:_&:' \
spyder/plugins/editor/widgets/tests/test_editor.py || die

# RuntimeError: Unsafe load() call disabled by Gentoo. See bug #659348
sed -i -e 's:test_dependencies_for_binder_in_sync:_&:' \
spyder/tests/test_dependencies_in_sync.py || die

# No idea why this fails, no error just stops and dumps core
sed -i -e 's:test_arrayeditor_edit_complex_array:_&:' \
spyder/plugins/variableexplorer/widgets/tests/test_arrayeditor.py || die

# Assertion error, can't connect/remember inside ebuild environment
rm spyder/plugins/ipythonconsole/widgets/tests/test_kernelconnect.py || die

# Assertion error (pytest-qt), maybe we can't do shortcuts inside ebuild environment?
sed -i -e 's:test_transform_to_uppercase_shortcut:_&:' \
-e 's:test_transform_to_lowercase_shortcut:_&:' \
-e 's:test_go_to_line_shortcut:_&:' \
-e 's:test_delete_line_shortcut:_&:' \
spyder/plugins/editor/widgets/tests/test_shortcuts.py || die

distutils-r1_python_prepare_all
}

python_test() {
virtx pytest -vv
}

pkg_postinst() {
xdg_pkg_postinst

elog "To get additional features, optional runtime dependencies may be installed:"
optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
optfeature "Import Matlab workspace files in the Variable Explorer" sci-libs/scipy
optfeature "Run Cython files in the IPython console" dev-python/cython
optfeature "The hdf5/h5py plugin" dev-python/h5py
optfeature "The line profiler plugin" dev-python/spyder-line-profiler
optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
# spyder-autopep8 and spyder-vim do not have a release (yet)
# and are not compatible with >=spyder-4.0.0 at the moment
# optfeature "The autopep8 plugin" dev-python/spyder-autopep8
# optfeature "Vim key bindings" dev-python/spyder-vim
optfeature "Unittest support" dev-python/spyder-unittest
optfeature "Jupyter notebook support" dev-python/spyder-notebook
optfeature "System terminal inside spyder" dev-python/spyder-terminal
# spyder-reports not yet updated to >=spyder-4.0.0
# optfeature "Markdown reports using Pweave" dev-python/spyder-reports
}

0 comments on commit 27f413d

Please sign in to comment.