Skip to content

Commit

Permalink
dev-php/pecl-zmq: New package wrt Bug 325351
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
Brian Evans committed Jul 7, 2017
1 parent 7ac5ed5 commit 27fe16d
Show file tree
Hide file tree
Showing 4 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-zmq/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST zmq-1.1.3.tgz 82397 SHA256 c492375818bd51b355352798fb94f04d6828c6aeda41ba813849624af74144ce SHA512 0f03016e315a6c6a1e1d6eca1e20564834d2a924cef06af1b38693933f1e5a094c37e9c432705a64f61d95e82655f61358fc7783e7a6f06c7dd9ad84fc6f7bbc WHIRLPOOL 3bfab5d373e52686c236a48d57280a99d7e87e018722003787a8d458a8a503f536cd89bf7cf11d8c6fb5db910d9fd45168caba6cc15032ecda9db08a7f57a95b
13 changes: 13 additions & 0 deletions dev-php/pecl-zmq/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>PHP</name>
</maintainer>
<longdescription lang="en">
</longdescription>
<use>
<flag name="czmq">Use the czmq high level bindings</flag>
</use>
</pkgmetadata>
23 changes: 23 additions & 0 deletions dev-php/pecl-zmq/pecl-zmq-1.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_PHP="php5-6 php7-0 php7-1"

inherit php-ext-pecl-r3

KEYWORDS="~amd64 ~x86"

DESCRIPTION="PHP Bindings for ZeroMQ messaging"
LICENSE="BSD"
SLOT="0"
IUSE="czmq"

RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
DEPEND="${RDEPEND} virtual/pkgconfig"

src_configure() {
local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
php-ext-source-r3_src_configure
}
31 changes: 31 additions & 0 deletions dev-php/pecl-zmq/pecl-zmq-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

USE_PHP="php5-6 php7-0 php7-1"

inherit php-ext-pecl-r3 git-r3

KEYWORDS=""

DESCRIPTION="PHP Bindings for ZeroMQ messaging"
LICENSE="BSD"
SLOT="0"
IUSE="czmq"

RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
DEPEND="${RDEPEND} virtual/pkgconfig"
SRC_URI=""
EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
EGIT_CHECKOUT_DIR="${PHP_EXT_S}"

src_unpack() {
git-r3_src_unpack
php-ext-source-r3_src_unpack
}

src_configure() {
local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
php-ext-source-r3_src_configure
}

0 comments on commit 27fe16d

Please sign in to comment.