Skip to content

Commit

Permalink
dev-qt/qtsql: 5.15.2-r10 version bump at KDE c2ea67ec
Browse files Browse the repository at this point in the history
EAPI-8

Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Aug 25, 2021
1 parent eaf8168 commit 2803558
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtsql/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST qtbase-5.15.2-c2ea67ec.tar.gz 67964503 BLAKE2B 2f55d1913d840a9150912074e81b7ebc38d86dbe259a51f65924868d97ed0cd5852fd6387e85933e956b0bd80404284b9e0f01506080f154751c0e1cf27ba398 SHA512 40eeaca1698613ab0c756053b58737cbef9fceed7cf7007aec5b558f992675a25d304ec83afdc7eab34bb854149d4e0ce61f2cc03003b553b4fc8a786f258e17
DIST qtbase-5.15.2-gcc11.patch.xz 1208 BLAKE2B a2e5764b723adda991eca5b84cf8e15437a4832febd12e3c93cdc394931af666e17c01e229e9be7e0efc446a955cc26388c0f93cadfcabd93cc6b6f03bb41eb0 SHA512 da3a41ea5d9573a029946d26b26d51d6dce9c8b91db6d78ca71d8343d3ceb5010d21750dcb45abb663e227b5f068985ff4ed51da07efd17c64cc8dd5aef8f3e4
DIST qtbase-everywhere-src-5.15.2.tar.xz 50179672 BLAKE2B 0e4bdaab43cf59664bde89f87ea260c39acc2ef866d8629d41d9c326cab0ab68bcd943c86a472ae74bc9fb0b7ad50795ccb66275bb6b77d1fcf0a38b5662cb42 SHA512 a549bfaf867d746ff744ab224eb65ac1bdcdac7e8457dfa379941b2b225a90442fcfc1e1175b9afb1f169468f8130b7ab917c67be67156520a4bfb5c92d304f9
57 changes: 57 additions & 0 deletions dev-qt/qtsql/qtsql-5.15.2-r10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

KDE_ORG_COMMIT=c2ea67ecefe049f6e9bb8f910d7f9c60319d8619
QT5_MODULE="qtbase"
inherit qt5-build

DESCRIPTION="SQL abstraction library for the Qt5 framework"
SLOT=5/$(ver_cut 1-3) # bug 639140

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi

IUSE="freetds mysql oci8 odbc postgres +sqlite"

REQUIRED_USE="
|| ( freetds mysql oci8 odbc postgres sqlite )
"

DEPEND="
~dev-qt/qtcore-${PV}:5=
freetds? ( dev-db/freetds )
mysql? ( dev-db/mysql-connector-c:= )
oci8? ( dev-db/oracle-instantclient:=[sdk] )
odbc? ( dev-db/unixODBC )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
"
RDEPEND="${DEPEND}"

QT5_TARGET_SUBDIRS=(
src/sql
src/plugins/sqldrivers
)

QT5_GENTOO_PRIVATE_CONFIG=(
:sql
)

src_configure() {
local myconf=(
$(qt_use freetds sql-tds plugin)
$(qt_use mysql sql-mysql plugin)
$(qt_use oci8 sql-oci plugin)
$(qt_use odbc sql-odbc plugin)
$(qt_use postgres sql-psql plugin)
$(qt_use sqlite sql-sqlite plugin)
$(usev sqlite -system-sqlite)
)

use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")

qt5-build_src_configure
}

0 comments on commit 2803558

Please sign in to comment.