Skip to content

Commit

Permalink
dev-php/pecl-apcu: Version bump to 5.1.10
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/649512
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Brian Evans committed Mar 6, 2018
1 parent 73ec700 commit 2844500
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/pecl-apcu/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST apcu-4.0.11.tgz 119535 BLAKE2B 2c1f8a0463b2802b11ae679987807127556b04fb099e4872bff9d1ea51c633140d978b66373eb987d5207403ed9389e58f1afa7ca94360680d9a9693230fb87a SHA512 e3b97066240e33850419e96f0fd9df0e66ee3b0fa238c418e07ac639d07439e9edfa1696e56a620e33f1ffc0993c57bde585b0c170b22995e7d5c0ae550b7899
DIST apcu-5.1.10.tgz 111937 BLAKE2B 87bf86b43a775c38b232e4acd876f5c63628fc095747fecc26109fddc0473672180e3886dd613fa426772ea53aa8d7f46d08ec3e3383f6ce53be2f63a9ff066b SHA512 fdf82f2b46231849b373f50d1255bcedab8fbefa7ded7c157649cf6406fb593cc2f4e63ca7d3cecfbadb4533ecd8d0ad80e198626dc1489cea8a22ba87ca583a
DIST apcu-5.1.8.tgz 111260 BLAKE2B eb41b1af33500ed9ddbbcb5e1a92884af4b356e16cf76c70f75a8853522cc91af1c156cc0bbd464fce539a138bf4e2ead5101810223b0f1bb91cd062850ef08e SHA512 4f377389e713bcae5534c64ea28f72c20ab2176aa758188c4d956c1f2370be49bc33dd2a1db43941fff5344a164aaeebc4e73e6d579f62d17334bcc520171526
DIST apcu-5.1.9.tgz 111049 BLAKE2B c7138f65d73a056e4a34972098c2b543ad6d96d0d8215e82757c457cc8938af48fea842e006c79c83deee4060cdc94047764930592eef03c5f347abeb7730897 SHA512 3e9b29a293b5bfb29283dd650907bfb9f31a1cb99ef908021d3869c3e3ae4051a2c45aab27275e90b0a2fa94c35cc9e170637dc539184d955f3f13dc09cba060
80 changes: 80 additions & 0 deletions dev-php/pecl-apcu/pecl-apcu-5.1.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PHP_EXT_NAME="apcu"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS=( NOTICE README.md TECHNOTES.txt TODO )

# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
# This allows us to depend on the other slot
USE_PHP="php5-6 php7-0 php7-1 php7-2"

inherit php-ext-pecl-r3

# However, we only really build for 7.x; so redefine it here
USE_PHP="php7-0 php7-1 php7-2"

KEYWORDS="~amd64 ~x86"

DESCRIPTION="Stripped down version of APC supporting only user cache"
LICENSE="PHP-3.01"
SLOT="7"
IUSE="+mmap"

DEPEND=""
RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-apcu:0[php_targets_php5-6] )"

LOCKS="pthreadmutex pthreadrw spinlock semaphore"

LUSE=""
for l in ${LOCKS}; do
LUSE+="lock_${l} "
done

IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"

REQUIRED_USE="^^ ( $LUSE )"

src_prepare() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
php-ext-source-r3_src_prepare
else
eapply_user
fi
}

src_configure() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
local PHP_EXT_ECONF_ARGS=(
--enable-apcu
$(use_enable mmap apcu-mmap)
$(use_enable lock_pthreadrw apcu-rwlocks)
$(use_enable lock_spinlock apcu-spinlocks)
)

php-ext-source-r3_src_configure
fi
}

src_install() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
php-ext-pecl-r3_src_install

insinto /usr/share/php7/apcu
doins apc.php
fi
}

pkg_postinst() {
if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
elog "The apc.php file shipped with this release of pecl-apcu was"
elog "installed into ${EPREFIX}/usr/share/php7/apcu/."
elog
elog "If you depend on the apc_* functions,"
elog "please install dev-php/pecl-apcu_bc as this extension no longer"
elog "provides backwards compatibility."
fi
}

0 comments on commit 2844500

Please sign in to comment.