forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-php/sebastian-object-reflector: bump to v2.0.4
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <[email protected]>
- Loading branch information
Showing
2 changed files
with
41 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST sebastian-object-reflector-1.1.1.tar.gz 4755 BLAKE2B c549186722bde6625d44478dc90023511cd4e2fb9fe206b08881746e4443275b20eaad86a13bc202b3f464cad7239aac28da9962db7a97b9c789534424cb3ead SHA512 42dc43d1a606b1aedf2cc40443139d115fc38a50a2e51d2b4d72ecededf39bf5cecbed6d1bb002dbb6f7bd3c7da50d9436f7489f9078d52d61af7777f31f5e57 | ||
DIST sebastian-object-reflector-1.1.2.tar.gz 4814 BLAKE2B 0692da7e50e6ff262395ece9bae1e02138bb3d86bd8b992b32d1eff9e3eabf5a1b3246e9e117314eaf49fdc5ed12b599bfb6fdab7de45506b392bf1d7dd94879 SHA512 2cfbc24d2f2105000ba039226e6dc399b847d60ca84f6643755c8cfa2d5efe3259da2e7762670ab5d330fe8075eca3124dbfe0a4780dc873e39e8c1420267c4b | ||
DIST sebastian-object-reflector-2.0.4.tar.gz 3366 BLAKE2B 9ceb1666e2e1e3679b66473b48a9c0a79fb905a7f0b2dbc5ba36766c1a15ba9ea5678da7a15664ef63a1a7fb1add80535da4ff065a356d085d966704e5647e3f SHA512 e7f9932a7a7c123008490a07bd7fb0a06acd6f0c39d1efd8de677a7ab9af3d98d72d8cf6c3a06ca15f869069a6709f1f70437cefc9c171b4f13436f68ab7112f |
40 changes: 40 additions & 0 deletions
40
dev-php/sebastian-object-reflector/sebastian-object-reflector-2.0.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
MY_PN="${PN/sebastian-/}" | ||
|
||
DESCRIPTION="Allows reflection of object attributes, including inherited and non-public ones" | ||
HOMEPAGE="https://phpunit.de" | ||
SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86" | ||
IUSE="" | ||
|
||
BDEPEND="dev-php/theseer-Autoload" | ||
|
||
RDEPEND="dev-php/fedora-autoloader | ||
>=dev-lang/php-7.3:*" | ||
|
||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
phpab \ | ||
--output src/autoload.php \ | ||
--template fedora2 \ | ||
--basedir src \ | ||
src \ | ||
|| die | ||
} | ||
|
||
src_install() { | ||
insinto /usr/share/php/SebastianBergmann/ObjectReflector | ||
doins -r src/. | ||
|
||
einstalldocs | ||
} |