Skip to content

Commit

Permalink
dev-libs/xml-security-c: Allow for compiling with GCC 6
Browse files Browse the repository at this point in the history
Gentoo-bug: 594234
* EAPI=6

Package-Manager: portage-2.3.0
  • Loading branch information
SoapGentoo committed Sep 18, 2016
1 parent 37c95d5 commit 28e20b4
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 10 deletions.
36 changes: 36 additions & 0 deletions dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
Fix building with C++14, which errors out due to bool -> T* conversions
See also: https://bugs.gentoo.org/show_bug.cgi?id=594234

--- a/xsec/enc/OpenSSL/OpenSSLCryptoSymmetricKey.hpp
+++ b/xsec/enc/OpenSSL/OpenSSLCryptoSymmetricKey.hpp
@@ -151,7 +151,7 @@
SymmetricKeyMode mode = MODE_CBC,
const unsigned char * iv = NULL,
const unsigned char* tag = NULL,
- unsigned int taglen = NULL);
+ unsigned int taglen = 0);

/**
* \brief Continue an decrypt operation using this key.
--- a/xsec/enc/XSECCryptoSymmetricKey.hpp
+++ b/xsec/enc/XSECCryptoSymmetricKey.hpp
@@ -185,7 +185,7 @@
SymmetricKeyMode mode = MODE_CBC,
const unsigned char* iv = NULL,
const unsigned char* tag = NULL,
- unsigned int taglen = NULL) = 0;
+ unsigned int taglen = 0) = 0;

/**
* \brief Continue a decrypt operation using this key.
--- a/xsec/tools/checksig/InteropResolver.cpp
+++ b/xsec/tools/checksig/InteropResolver.cpp
@@ -645,7 +645,7 @@

}

- return false;
+ return NULL;

}

17 changes: 7 additions & 10 deletions dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils
EAPI=6

DESCRIPTION="Apache C++ XML security libraries"
HOMEPAGE="http://santuario.apache.org/"
Expand All @@ -25,11 +23,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"

DOCS=( CHANGELOG.txt NOTICE.txt )

src_prepare() {
epatch "${FILESDIR}/1.6.1-nss-compilation-fix.patch"
epatch_user
}
PATCHES=(
"${FILESDIR}/${PN}-1.6.1-nss-compilation-fix.patch"
"${FILESDIR}/${PN}-1.7.3-fix-c++14.patch"
)

src_configure() {
econf \
Expand All @@ -43,7 +40,7 @@ src_configure() {
src_install() {
default
if use examples ; then
insinto /usr/share/doc/${PF}/examples
doins xsec/samples/*.cpp
docinto examples
dodoc xsec/samples/*.cpp
fi
}

0 comments on commit 28e20b4

Please sign in to comment.